Query Is Not Using Index
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: Query Is Not Using Index

  1. #1
    Join Date
    Sep 2000
    Posts
    305

    Query Is Not Using Index

    Hi Friends,

    I have created on Index on a table when I execute one query where the Indexed column is in where clause but it is not using Index I tried through Hints also but still it is not using Index any idea why it is not using Index?

    Thanks in Advance
    Shailendra

  2. #2
    Join Date
    Feb 2000
    Location
    Singapore
    Posts
    1,758
    Shailendra,
    Is it a composite index? Is the leading column of the index in where clause?
    Can you post your query (with hint) and indexed columns? Also Oracle version?
    Sanjay G.
    Oracle Certified Professional 8i, 9i.

    "The degree of normality in a database is inversely proportional to that of its DBA"

  3. #3
    Join Date
    Sep 2000
    Posts
    305
    thanks for reply Sanjay

    I got the solution there was some problem in the query I rectify that now it is working fine

    Thanks again
    Shailendra

  4. #4
    Join Date
    Nov 2000
    Location
    Baltimore, MD USA
    Posts
    1,339
    Thanks for the closure.

    However, in the future, might I suggest a little more detail in the question?

    "My car doesn't work and I don't know why" isn't much to go on, is it?

    If you have a problem with a query... provide the query, and the plan.

    If you have a problem with an index... provide the index.

    Please take a moment and read the 'sticky' post at the top of this forum.

    Thanks,

    - Chris
    Christopher R. Long
    ChrisRLong@HotMail.Com
    But that's just my opinion. I could be wrong

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width