Installation of Oracle in Redhat 9.0
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: Installation of Oracle in Redhat 9.0

  1. #1
    Join Date
    May 2003
    Location
    India
    Posts
    4

    Installation of Oracle in Redhat 9.0

    Hi All,

    I want to install Oracle in redhat linux 9.0. I am a newbie and I do not know exactly what should I do. I went through the documents supplied by the technet.oracle.com on the installtion of Oracle 8i.

    I have a doubt like do I need Java to be installed before installing the Oracle 8i? I tried to install Oracle after installing the latest RPM from IBM site for Java. But when I installed Oracle, it showed me configuration problem in packages path of Java and I do not know How to configure Java. So please reply me as I am stuck and please guide e to a place where I can get the information regarding this.

    So please ...

    Lot of Thanks in Advance.

    Bye
    Thanks and Regards
    Emmanuel mathew
    Thanks and Regards
    Emmanuel Mathew

  2. #2
    Join Date
    May 2003
    Location
    India
    Posts
    4

    Got the Answer for it

    Hi All,

    I got a few links which can save me I think .So let me check those and sure I will tell you good people whether I won the war or not.

    Thanks for everything
    Thanks and Regards
    Emmanuel Mathew

  3. #3
    Join Date
    Nov 2001
    Location
    Singapore
    Posts
    182
    Hi

    U No need to install Java 1st. Oracle itself has all the java components which are necessary to work with oracle



    Tks
    Gangu
    J Gangadhar

  4. #4
    Join Date
    Mar 2001
    Location
    Ireland/Dublin
    Posts
    684

    Oracle 8.1.7 installation on Red Hat 9

    Oracle 8.1.7 installation on Red Hat 9:
    I spent a month trying to install Oracle8i on RedHat9.

    These are the steps I made:

    1) Installed RH Server configuration, downloaded from www.redhat.com
    2) Created groups and user oracle for Oracle install (set all environment settings)
    export ORACLE_OWNER=oracle
    export ORACLE_HOME=/usr/local/oracle/product/8.1.7
    export ORACLE_SID=cust
    export LD_LIBRARY_PATH=$ORACLE_HOME/lib
    export NLS_LANG=AMERICAN_AMERICA.UTF8
    export LANG=en_US.iso-8859-1
    export ORA_NLS33=$ORACLE_HOME/ocommon/nls/admin/data
    export NLS_DATE_FORMAT='DD/MM/YYYY HH24:MI:SS'
    export PATH=$PATH:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/X11R6/bin:$ORACLE_HOME/bin:/usr/X11R6/bin:/home/oracle/bin
    3) Prepared patchsets 8.1.7.3 & 8.1.7.4
    4) Copied all RPMS on HD and installed all "rpm -i compat-*", except of 2 rpms which required additional packages installed
    rpm -i compat-gcc-java-7.3-2.96.118.i386.rpm compat-libstdc++-7.3-2.96.118.i386.rpm compat-gcc-7.3-2.96.118.i386.rpm compat-libstdc++-devel-7.3-2.96.118.i386.rpm compat-gcc-c++-7.3-2.96.118.i386.rpm compat-libgcj-7.3-2.96.118.i386.rpm compat-pwdb-0.62-3.i386.rpm compat-gcc-g77-7.3-2.96.118.i386.rpm compat-libgcj-devel-7.3-2.96.118.i386.rpm compat-slang-1.4.5-5.i386.rpm
    5) Installed: jdk-1.3.1_01.i386.rpm
    6) Made a link /usr/local/java -> /usr/java/jdk1.3.1_01/
    7) Installed: compat-egcs-6.2-1.1.2.16.i386.rpm, compat-glibc-6.2-2.1.3.2.i386.rpm, compat-libs-6.2-3.i386.rpm (I got them from RH73 on http://rpmfind.net)
    8) During the first ./runInstaller run I did not set LD_ASSUME_KERNEL=2.2.5, because it worked and without this setting.
    9) Update root.sh:
    A popup window then appears asking to execute the script /usr/local/oracle/product/8.1.7/root.sh as user root.
    Before we execute the script we correct a few errors (taken from this note).
    Line 102
    RMF=/bin/rm -f
    is changed into
    RMF="/bin/rm -f"
    and line 156
    RUID=`/usr/bin/id|$AWK -F\( '{print $2}'|$AWK -F\) '{print $1}`
    is changed into
    RUID=`/usr/bin/id|$AWK -F\( '{print $2}'|$AWK -F\) '{print $1}'`
    10) Runing root.sh gave me an error about file which did not existed (I do not remmebr which one, possible dbsnmp)
    I ignored this error.
    11) Ignore all errors during installation.
    12) Install patch glibc-2.1.3-stubs.tar and run setup_stubs.sh
    13) export LD_ASSUME_KERNEL=2.2.5
    14) Install patchset 8.1.7.3, ignore all errors during installation.
    15) Install patchset 8.1.7.4, ignore all errors during installation.
    16) Install patch glibc-2.1.3-stubs.tar.gz and run setup_stubs.sh
    17) Copy lsnrctlO -> lsnrctl, tnslsnrO -> tnslsnr
    18) Run dbassist to create database
    19) Run netca to configure Listener
    Best wishes!
    Dmitri

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width