Can't connect to DB - Page 2
DBAsupport.com Forums - Powered by vBulletin
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Can't connect to DB

  1. #11
    Join Date
    Nov 2002
    Location
    Geneva Switzerland
    Posts
    3,142
    Originally posted by pascal01
    I'm getting an ORA-12560 TNS PROTOCOL ADAPTER ERROR.
    That's the one you get if the service ain't running.

    I'm getting tired (well past going home time): forget connecting as sys, use internal or just / I skrewed up there.
    "The power of instruction is seldom of much efficacy except in those happy dispositions where it is almost superfluous" - Gibbon, quoted by R.P.Feynman

  2. #12
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    Originally posted by pascal01
    Hi. I can't use svrmgrl anymore. I'm getting an ORA-12560 TNS PROTOCOL ADAPTER ERROR. The ORACLE_HOME, ORACLE_SID, ORACLE_PATH are all set correctly. The listener and service is started. Looks like something screwy is going on. Please help thanks.
    I'm guessing something is not setup correctly.

    Since this is Windoz, you might try rebooting a dozen times or so

    gee, I love unix....
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  3. #13
    Join Date
    May 2002
    Posts
    2,645
    Windows? Did someone say Windows? Try rebooting.

    Company policy doesn't allow me to stay on the phone while your system is rebooting, so please call back when your PC has finished rebooting.

    In the command prompt/MS-DOS window, what does echo %ORACLE_SID% return? If not the database you want to connect to, try (well, not "try" - there is only "do" or "do not") setting ORACLE_SID, then fire up svrmgrl.

    TNS-12560 very, very common when less-than-manly-almost-woman-or-elf-like users haven't set the environment variable correctly the way he-man-studly UNIX users do and can.

  4. #14
    Join Date
    Nov 2002
    Location
    Geneva Switzerland
    Posts
    3,142
    Oh shut up you two! You're jealous that UNIX doesn't have one solution that fits all problems.

    Pascal, Steven does have a point:
    if you set ORACLE_SID=FRED then OracleServiceFRED must be running . . . otherwise the ORA-12560 when you try to run svrmgrl. Typing errors in ORACLE_SID are probably a major cause of this.

    (UNIX people don't have trouble with typos - all possible 2-4 char combinations are valid commands - the question is what do they do? - if I remember correctly rm="restore and mount database")
    "The power of instruction is seldom of much efficacy except in those happy dispositions where it is almost superfluous" - Gibbon, quoted by R.P.Feynman

  5. #15
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    Try

    Code:
    rm -rf /home/users/DaPi > /dev/null 2>&1 &
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  6. #16
    Join Date
    Jul 2001
    Location
    Montreal
    Posts
    218
    Hi. I have a service called "OracleSericeAODB5" and my ORACLE_SID=AODB5. Keep getting this ORA-12560 error. Is it a registry problem maybe?

  7. #17
    Join Date
    May 2002
    Posts
    2,645
    In an MS-DOS window, set ORACLE_SID to the name of the service/database you want to connect to. You can set an environment variable via My Computer>right click>Properties>Environment with Variable = ORACLE_SID and Value = AODB5. If you do that, then whenever you invoke an MS-DOS window, ORACLE_SID will be set to AODB5. Otherwise, do a set ORACLE_SID=dbname at the command prompt.

  8. #18
    Join Date
    Nov 2002
    Location
    Geneva Switzerland
    Posts
    3,142
    Originally posted by marist89
    rm -rf /home/users/DaPi > /dev/null 2>&1 &
    Since we are discussing an NT prob, Jeff should have explained this - I will do my best (my comments are in parentheses):

    rm = restore and mount database (self-evident)
    -rf = do not recover and perform full backup (UNIX commands are so powerful you must specify what they should NOT do, options to be excluded are prefixed with a minus sign)
    /home/users/DaPi = location of database (this is an extreme example, UNIX people usually can not type such long character strings)
    > = is better than (thes are called "pipe" symbols, this refers to the smoking habits of the early UNIX gurus while debating the relative merits of the methods that these symbols are applied to - other examples: << = much worse than, | = pretty much the same as)
    /dev/null = extremely stupid developer (search for "Mr.Hanky" on this site for further details on dealing with this)
    2>&1 = two is better than and-one (this notation is taken from that of musical rythmn and is used to synchronise processes running concurrently - this example gives two possibilites and indicates a preference for jazz)
    & = and . . . (a real UNIX speciality! this open-ended parameter allows the operating system to use spare machine cycles for other purposes, details depends on OS parameters defined during kernel compilation - garbage collection and ordering pizza are typical)

    HTH
    Last edited by DaPi; 05-05-2003 at 04:51 AM.
    "The power of instruction is seldom of much efficacy except in those happy dispositions where it is almost superfluous" - Gibbon, quoted by R.P.Feynman

  9. #19
    Join Date
    Jan 2001
    Posts
    2,828
    Hi Dapi

    I have a interview comming up..so now i know how to backup thatnks for the explanation of rm -rf ...i will use this as an answer for backup and recovery.


    regards
    Hrishy

  10. #20
    Join Date
    Dec 2002
    Location
    Bangalore ( India )
    Posts
    2,434
    Originally posted by pascal01
    Is it a registry problem maybe?
    Should u have a doubt u shud try it...

    try setting the value for ORACLE_SID in the reg path

    HKEY_LOCAL_MACHINE\SOFTWARE\%ORACLE_BASE%\%Oracle_HOME%....


    Abhay.
    funky...

    "I Dont Want To Follow A Path, I would Rather Go Where There Is No Path And Leave A Trail."

    "Ego is the worst thing many have, try to overcome it & you will be the best, if not good, person on this earth"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width