Multiple Instances .. Listener Problem
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Multiple Instances .. Listener Problem

Hybrid View

  1. #1
    Join Date
    Jan 2002
    Posts
    78

    Multiple Instances .. Listener Problem

    Hi All,

    Ours is Oracle 8.1.6 on Red Hat Linux 7.3. We have installed two instances on the Same Server. We Create only one Listener for the Two instances at the server. The problem is when we are trying to connect from clients - The server is misbehaving like sometimes its not allowing us to get connect - Some times it making confusion with the passwords, tablespaces and schemas.

    For Example : The First Instance name is INSA and its Sytem password is Manager1 and Second Instance Name is INSB and Its system password is Manager2.

    At our Client we configured LOCAL NAMES and the server is in dedicated mode. At the Clients TNSNAMES.ORA FILE we configured the two instances as INSA and INSB.

    Then when we are connecting from client the SYSTEM/MANAGER1@INSA in showing the schema of SYSTEM's INSB and some times it is not allowing us to connect. But the same is working fine at the server. Then I thought it might be problem with listner and restarted the listener. then its working fine for some time and again giving the same problem.

    Can you please help me in identifing where the problem is and solving this.

  2. #2
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,448
    no error codes, no help

  3. #3
    Join Date
    Jan 2002
    Posts
    78
    Its sometimes ora-12154 -TNS: could resolve tnsnames. I checked with tnsping its working fine.
    Sometimes its connecting to another instance with this password

  4. #4
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,448
    well, seems to me is not a Oracle technical problem but rather your configuration problem

  5. #5
    Join Date
    Jan 2002
    Posts
    78
    When The Listener Status is showing like the below :

    Services Summary...
    PLSExtProc has 1 service handler(s)
    insA has 1 service handler(s)
    insA has 1 service handler(s)
    insB has 1 service handler(s)
    insB has 1 service handler(s)
    The command completed successfully

    Its working like the below from the client


    SQL> connect system/manager1@insA
    Connected.
    SQL> connect system/manager2@insB
    ERROR:
    ORA-01017: invalid username/password; logon denied


    Warning: You are no longer connected to ORACLE.
    SQL> connect system/manager1@insB
    Connected
    - But connecting to insA
    or saying this also invalid password

    If the Listener is showing only one service for each instance then its working fine

  6. #6
    Join Date
    Jan 2002
    Posts
    78
    I am also expecting the same. But What That configuration I made wrong ???

  7. #7
    Join Date
    Sep 2000
    Location
    Chennai, India
    Posts
    865
    Paste here the tnsnames.ora contents from the client where you are getting this error.

  8. #8
    Join Date
    Jan 2002
    Posts
    78
    INSA =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = IPADDRESS)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = insA)
    )
    )

    INSB =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = IPADDRESS)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = INSB)
    )
    )

    I added this by using netassist Wizard and I also tried the same by adding SRVR= DEDICATED in CONNECT_DATA

  9. #9
    Join Date
    Nov 2002
    Location
    New Delhi, INDIA
    Posts
    1,796
    What is IPADDRESS ?? is this host name or you didnot put any ipaddress over there
    Amar
    "There is a difference between knowing the path and walking the path."

    Amar's Blog  Get Firefox!

  10. #10
    Join Date
    May 2001
    Posts
    736
    can u check up both databases started with their own parameter files.Try once to startup with their own parameter files.Iam also getting doubt that your password file is corrupted due to some reason as it is not accepting the INSB system password.As lot of things are mixing up in your problem.Can u check these and what is the result.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width