I am having a problem with Oracle Import that has me pulling my hair out. Here’s the situation.

I have a client providing me an Oracle Export file (pertinent portion of the export log is below) 8i is running on NT 4 SP6a.

Connected to: Oracle8i Release - Production
JServer Release - Production
Export done in WE8ISO8859P1 character set and WE8ISO8859P1 NCHAR character set
Note: grants on tables/views/sequences/roles will not be exported
Note: indexes on tables will not be exported
Note: constraints on tables will not be exported

About to export specified tables via Conventional Path ...
Current user changed to WEBSITE
. . exporting table BLA_BLA 99 rows exported
Export terminated successfully without warnings.

I am attempting import this file to a 9i server that has the character set WE8MSWIN1252. Before I run my import I set the following environmental variables:

I run my import and some characters are converted to ¿. (pertinent portion of the import log is below)

Connected to: Oracle9i Enterprise Edition Release - Production
With the Partitioning, OLAP and Oracle Data Mining options
JServer Release - Production

Export file created by EXPORT:V08.01.06 via conventional path
import done in WE8ISO8859P1 character set and AL16UTF16 NCHAR character set
import server uses WE8MSWIN1252 character set (possible charset conversion)
export server uses WE8ISO8859P1 NCHAR character set (possible ncharset conversion)
. importing SYSTEM's objects into SYSTEM
. importing WEBSITE's objects into WEBSITE
. . importing table "BLA_BLA" 99 rows imported
Import terminated successfully without warnings.

I suspect I am having the character conversion issue because the import thinks its using AL16UTF16 as the import NCHAR character set but I am setting it to WE8ISO8859P1 before I do the import. I am sure that the problem is not the export because I have viewed the export dump file and the ¿ character is not there.

Anyone have any ideas on how to resolve this?


Kevin Donovan