Getting an ORA-03113 end of communication channel
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: Getting an ORA-03113 end of communication channel

  1. #1
    Join Date
    Mar 2003
    Posts
    2

    Question Getting an ORA-03113 end of communication channel

    error when a particular trigger fires. Actually the error occurs at a specific assignment statement in the trigger. I can reproduce it however sometimes it seems to resolve itself and then reappear later on. I'm pretty sure nothing is wrong with the pl/sql code.
    Any insight appreceiated. Thanks.

  2. #2
    Join Date
    Mar 2003
    Posts
    2

    more info about the problem

    this is what the lsnrctl's status shows.

    ---------------------------------------------------------------------

    LSNRCTL> status
    Connecting to (ADDRESS=(PROTOCOL=tcp)(PORT=1521))
    STATUS of the LISTENER
    ------------------------
    Alias ORACLE_LISTENER
    Version TNSLSNR for 32-bit Windows: Version 9.2.0.1.0 - Produc
    tion
    Start Date 29-MAR-2003 12:41:41
    Uptime 0 days 2 hr. 30 min. 31 sec
    Trace Level off
    Security OFF
    SNMP OFF
    Listener Parameter File D:\ORACLE\OraHome\network\admin\listener.ora
    Listener Log File D:\ORACLE\OraHome\network\log\oracle_listener.log
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=HOME)(PORT=1521)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1ipc)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=HOME)(PORT=8080))(Presentation=HTTP)
    (Session=RAW))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=HOME)(PORT=2100))(Presentation=FTP)(
    Session=RAW))
    Services Summary...
    Service "PLSExtProc" has 1 instance(s).
    Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
    Service "oracledb" has 2 instance(s).
    Instance "oracledb", status UNKNOWN, has 1 handler(s) for this service...
    Instance "oracledb", status READY, has 1 handler(s) for this service...
    Service "oracledbXDB" has 1 instance(s).
    Instance "oracledb", status READY, has 1 handler(s) for this service...
    The command completed successfully
    LSNRCTL>
    --------------------------------------------------------------------

    Does the 2 instances of oracledb have something to do with this?

    Also the oracledbCore.log has stuff likes this in it showing something or other about an ACCESS_VIO on the insert...


    -------------------------------------------------------------------
    Oracle9i Enterprise Edition Release 9.2.0.1.0 - Production
    Process Id: 0x000003a0 Thread Id : 0x00000834 Time : Sat Mar 29 14:51:43
    Excp. Code: 0xc0000005 Excp. Type: ACCESS_VIO Flags: 0x00000000

    ------------------- Registers ----------------------------
    eip = 017f0d6f esp = 05aec6d4 ebp = 05aed6e8 edi = 00000010 esi = 06000010
    eax = 06000000 ebx = 0000000d ecx = 00000003 edx = 67e8b19c
    ecs = 0000001b eds = 00000023 ees = 00000023 ess = 00000023
    egs = 00000000 efs = 0000003b
    eflags = 00010206
    ------------------- End of Registers ---------------------

    ------------------- Instruction Disassembly --------------
    ------------------- End of Disassembly -------------------

    ------------------- Call Stack Trace ---------------------
    Frameptr RetAddr Param#1 Param#2 Param#3 Param#4 Function Name
    0x05aed6e8 00602a52 05b9e678 67e95704 67e95498 05b9e2ec __VInfreq__insrow+b1
    0x05aed770 0076c1c6 05b9e678 05aed7ec 00000000 67e95704 _insrow+66
    0x05aed844 00601afa 05b9e678 67e95498 00000000 05b9e2ec _insdrv.73+252
    0x05aed950 005f692c 67e95704 05aeda30 00000000 05bbcbc8 ..1.6_1.filter.73+11
    0x05aedcb4 00663a4e 00000004 00000003 05aede0c 0021f2e0 ..1.5_1.filter.29+12
    0x05aedf40 00ff35b0 0000003e 00000022 05aedf84 05aee734 _opiall0+84e
    0x05aee044 005dfc74 00000047 0000000f 05aee734 01991d50 _opial7+150
    0x05aee260 6050bd40 00000047 0000000f 05aee734 00000002 _opiodr+4d0
    0x05aee6fc 00628c1d 0021f2e0 00000047 05aee734 00000000 _ttcpip+a88
    0x05aef7a0 00627a91 00000000 00000000 0021f2e0 05b82d90 _opitsk+2f9
    0x05aef8a8 005dfc74 0000003c 00000004 05aefbd4 01991ca0 _opiino+601
    0x05aefac4 007dd4e8 0000003c 00000004 05aefbd4 00000000 _opiodr+4d0
    0x05aefb54 00714d8e 0000003c 00000004 05aefbd4 00000000 _opidrv+238
    0x05aefb6c 0070fb5f 05aefbf0 0000003c 00000004 05aefbd4 _sou2o+1e
    0x05aefc08 00710511 00000002 05aefe74 00df7298 77d4ea27 _opimai+10f
    0x05aeffb4 77e8758a 00df7c34 00df7298 77d4ea27 00df7c34 _OracleThreadStart@4
    0x05aeffec 00000000 007101b0 00df7c34 00000000 00000000 0x77e8758a
    ------------------- End of Stack Trace -------------------

    ------------------- Raw Stack Dump -----------------------
    Address Dump of bytes
    0x05aec6d4 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 ................
    0x05aec6e4 00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00 ................
    ---------------------------------------------------------------------

  3. #3
    Join Date
    Jul 2001
    Location
    Singapore(Asia)-WebCentre business company
    Posts
    456
    hi,

    if my memory serve me correctly..sometimes intermittent network connection will result in remote user accessing Oracle database to encounter this error...comments?

    WH

  4. #4
    Join Date
    Aug 2000
    Location
    Singapore
    Posts
    323
    Hi

    Check the SQLNET.EXPIRE_TIME. If it is more than zero, set it to zero and try.

    Hope this helps.
    Nagesh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width