ora-12637 packet received failed
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: ora-12637 packet received failed

  1. #1
    Join Date
    Aug 2000
    Location
    Jolo, Sulu
    Posts
    639

    ora-12637 packet received failed

    Hi friends,

    Ora 9.2 on win2000

    I'm quite confused by this error, ora-12637 in our server.
    When I use the command:

    c:\> sqlplus system/manager ( it can connect)

    but if i use

    C:\> sqlplus system/manager@ora9 (it produce ora-12637)

    the above commands is issued on the server itself.

    but when I issue the command on the client PC

    c:\> sqlplus system/manager@ora9 (it can connect ) I use the same
    tnsnames.ora on the server....

    Why am i having error on the server and not on the cliemt?


    Please help....and thank you all in advance

  2. #2
    Join Date
    Sep 2000
    Location
    Chennai, India
    Posts
    865
    Do a tnsping ora9 on the server and see where it is pointing to for the parameter files. It might be pointing to a previous installation directory that does not contain ora9 in the tnsnames.ora

    Rectify this and that should solve your problem.

    HTH.

  3. #3
    Join Date
    Sep 2000
    Location
    Chennai, India
    Posts
    865

    Re: ora-12637 packet received failed

    Originally posted by kris123
    I'm quite confused by this error, ora-12637 in our server.
    TNS-12637 Packet receive failed

    Cause: A process was unable to receive a packet from another process. Possible causes include:

    The other process was terminated.
    The machine on which the other process is running went down.
    Some other communications error occurred.
    Action: If the cause is not obvious, contact Oracle Support Services.
    HTH.

  4. #4
    Join Date
    Aug 2000
    Location
    Jolo, Sulu
    Posts
    639
    Hi friend,

    I did

    c:\> tnsping ora9

    Used parameter files:
    c:\>dbs_home\network\admin\sqlnet.ora

    TNS-03505: Failed to resolve name

    Why is that?....


    Thanks agaim

  5. #5
    Join Date
    Aug 2000
    Location
    Jolo, Sulu
    Posts
    639
    Hi,

    Sorry, this is the correct one

    c:\> tnsping ora9

    Used TNSNAMES adapter to resolve the alias
    Attempting to contact (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP) (HOST = NTSERV1)(PORT = 1521)))(CONNECT_DATA = (SERVICE_NAME = ora9))) OK (50 msec)


    I think no error here?....

    Does server domain affect the service name like NTSERV1.DOMAIN.COM
    and service name ORA9.DOMAIN.COM.

    I'm really confused on what is the right way of naming service name.

  6. #6
    Join Date
    Dec 2002
    Location
    Bangalore ( India )
    Posts
    2,434
    In Sqlnet.ora add

    NAMES.DEFAULT_DOMAIN = DOMAIN.COM

    Abhay.
    funky...

    "I Dont Want To Follow A Path, I would Rather Go Where There Is No Path And Leave A Trail."

    "Ego is the worst thing many have, try to overcome it & you will be the best, if not good, person on this earth"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width