8i fails to find shared libraries
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: 8i fails to find shared libraries

  1. #1
    Join Date
    May 2002
    Location
    Western Australia
    Posts
    233

    8i fails to find shared libraries

    Hi folks,

    OS HP-UX 11i
    DBMS 8.1.7.3 Patchset 2189751


    We have just migrated to 8.1.7 (and tomorrow we're getting a telephone!) and have come up against a major pain.

    If we try a local connection thorugh SQL*Plus we get :

    [hpips2] /home/opdba> sqlplus (user)/(password)

    SQL*Plus: Release 8.1.7.0.0 - Production on Wed Mar 26 09:02:50 2003

    (c) Copyright 2000 Oracle Corporation. All rights reserved.

    /usr/lib/pa20_64/dld.sl: Unable to find library 'libjox8.sl'.
    ERROR:
    ORA-12547: TNS:lost contact

    The LD_LIBRARY_PATH points to $ORACLE_HOME/lib64 and SHLIB_PATH to $ORACLE_HOME/lib. This issue does not arise if we specify a connection string i.e. sqlplus user/password@hpips2_acdev.

    Interestingly we can connect successfully if we logon to unix with the account owning the oracle installation regardless of whether we supply a connection string or not.

    Kind of suggests a permissions issue (not oracle executable, already checked)but not sure where else to look.

    I would check Metalink but the client seems to think that support is a luxury!!!

    Any ideas would be a great help

    Nick

  2. #2
    Join Date
    May 2002
    Posts
    2,645
    From MetaLink - someone with the same problem

    Ensure that the following are true
    1)$LD_LIBRARY_PATH contains the $ORACLE_HOME/lib64 dir.
    2)$LD_LIBRARY_PATH does not contains the $ORACLE_HOME/lib dir.
    3)$SHLIB_PATH contains the $ORACLE_HOME/lib dir.
    4)$SHLIB_PATH does not contains the $ORACLE_HOME/lib64 dir.
    5)libjox8.sl'. does exist in the $ORACLE_HOME/lib.

  3. #3
    Join Date
    May 2002
    Location
    Western Australia
    Posts
    233
    Thanks for that Steve,

    (Can't believe this lot have had three months and are still thinking about getting a CSI.)

    A "chatr" on the Oracle executable show the search order as LD_LIBRARY_PATH first, followed by SHLIB_PATH and then named directories hence the reason why LD_LIBRARY_PATH is for the 64 bit modules only.

    We've followed the path setup and got round the problem temporarily by putting a softlink in the /usr/pa20_64 directory.

    What I don't get is what causes the problem. I was told the install went fine but could this be a linking problem?

    Cheers

    Nick

  4. #4
    Join Date
    May 2002
    Posts
    2,645
    Continuation of the same answer:

    Regarding the relink problem
    Ensure that the Kernel parameters MAXDSIZE and MAXDSIZE_64BIT are both set to considerably more than the default. MAXDSIZE should be atleast 300M. Also make sure that the swap space is big enough.

    Also , ensure that,

    1. The /tmp directory has enough free space as mentioned in the installation guide.

    2. All the required OS patches have been applied on the server as recommended in the installation guide.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width