Agent Configuration Assistant failed during Oracle 9i installation
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Agent Configuration Assistant failed during Oracle 9i installation

  1. #1
    Join Date
    Sep 2001
    Location
    Mexico
    Posts
    93

    Agent Configuration Assistant failed during Oracle 9i installation

    Hi friends,

    I have a problem installing Oracle 9i R2 on AIX 5.1. I have followed the docs & installation guide and also I have applied OS patches.
    But the Agent Configuration Assistant step fails during installation.
    I just want a basic installation (RDBMS & Listener), and I'm not installing neither Enterprise Manager nor Intelligent Agent.
    But I don't know how to avoid/fix the Agent Configuration step during installation. I think Agent Configuration Assistant is part of the Intelligent Agent installation, and my OS prerrequisites are not prepared for the Intelligent Agent Installation. I don't want to install neither Intelligent Agent nor Agent Configuration, but the 9i installation by default tries to install Agent Configuration Assistant even I HAVE NOT SELECTED INTELLIGENT AGENT INSTALLATION.
    The big problem also is that net manager is not running because there is a Java problem. I don't know if the Agent Configuration error during installation is related to this problem.

    I need to know :
    1) How to Avoid/Fix the Agent Configuration Assistant during the installation on AIX.

    2) Net Manager sends me an error and it cannot execute . The error message is:
    "Error loading native library: lbnjnji9.so"

    If either you have experience installing 9i R2 on Aix 5.1 or you know how to solve these problems, PLEASE HELP ME. Your answers will be very appreciated.

    Regards and thanks in advance.

  2. #2
    Join Date
    Sep 2001
    Location
    Mexico
    Posts
    93

    I already solved the problem.

    Ok, this was very very tricky.


    In found the solutions in Metalink (apply only to AIX 5L- RDBMS 9iR2).


    1) For avoid the Agent Configuration Assistant fails during Oracle installation, please do this:

    a) Issue resolved by adding the following line in the snmpd.conf
    file:

    smux 0.0 "" xx.xx.xx.xx

    where xx.xx.xx.xx is the ip of the local machine.

    Also added the domain name (as an alias with the ip) as
    entered during the runInstall process, to the /etc/hosts
    file.


    refer
    Doc ID: 356983.995


    b) Also I give permissions to the oracle account on the "/etc"
    (I don't remember the Metalink reference)

    I just apply this command as root:
    chmod 777 /etc
    (well , I'm pretty sure that there are other ways to solve this in
    UNIX but I'm not an expert).

    2) For avoid the "netmgr java problem" I need to configure the libpath to "lib32" instead the "lib" path.

    export LD_LIBRARY_PATH=$ORACLE_HOME/lib32:/lib:/usr/lib

    refer :
    Doc ID: 439948.999


    I really expect this will help some one.

    Bye again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width