Hi Jim, please help me for my post ORA-27040
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: Hi Jim, please help me for my post ORA-27040

  1. #1
    Join Date
    Apr 2002
    Posts
    291

    Hi Jim, please help me for my post ORA-27040

    Hi Jim,
    Please look into my post ORA-27040, I'm in very very critical position. I'm getting that error continuosly. I tried with all the directories i had in my box, and with all the permissions 777 also i tried, but couldn't get. All the time,its saying the same error:

    ERROR at line 1:
    ORA-01501: CREATE DATABASE failed
    ORA-00301: error in adding log file 'u09/oradata/cmsdev/redo1a.log' - file
    cannot be created
    ORA-27040: skgfrcre: create error, unable to create file
    Linux Error: 2: No such file or directory


    Please help me...

    There was a softlink for my init.ora to another directory /u01/app/oracle/oradata/cmsdev/pfile from $ORACLE_HOME/dbs. I took a backup of the init.ora file and removed those two files from both the directories and copied back into $ORACLE_HOME/dbs . By this way, will the softlink will be removed or still it exists. Metalink says, this error usually comes when there is any soft link exists for a file . But i recreated it ,(using the same old file only).

    Please help me
    PNRDBA

  2. #2
    Join Date
    Dec 2001
    Location
    Brazil
    Posts
    282
    Maybe the logfiles already exist. Check if they do, then remove them and try to recreate the database.



    F.

  3. #3
    Join Date
    Apr 2001
    Location
    Bangalore, India
    Posts
    727
    Hi

    The error message is so clear man.

    Missing the / in the begining. You original statement is 'u09/oradata/cmsdev/redo1a.log' and change to '/u09/oradata/cmsdev/redo1a.log' to resolve the problem.


    Thomas
    Thomas Saviour(royxavier@yahoo.com)
    Technical Lead (Databases)
    Thomson Reuters (Markets)

    http://ora600tom.wordpress.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width