help with procedure
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: help with procedure

  1. #1
    Join Date
    Mar 2001
    Posts
    78
    I am executing a stored procedure that select from a remote database and and inserts the data in my development database(based on a certain criteria). I recieved this error when the procedure executed:

    ORA-02041: client database did not begin a transaction
    ORA-02063:

    Only inserts, no updates
    Any idea what went wrong? How can I fix it?
    NOTE: My every 500 records inserted, I do a commit

  2. #2
    Join Date
    Sep 2000
    Posts
    41
    Hi,
    How are you accessing the remote database thru your procedure.
    Are you using DB_LINK. If yes check with the remote database whether it is up and running.

    The procedure code would also help analysing the problem.

    Regards,

    Amit

  3. #3
    Join Date
    Nov 2000
    Location
    Baltimore, MD USA
    Posts
    1,339
    Any resolution to this or anyone else have any ideas?

    I just got pinged on the same problem happening in one of the projects here and I didn't have anything for them.

    Any help is appreciated,

    - Chris
    Christopher R. Long
    ChrisRLong@HotMail.Com
    But that's just my opinion. I could be wrong

  4. #4
    Join Date
    Mar 2001
    Posts
    314
    Check metalink note 98347.1. Seems to be an ODBC/OCI combo.

    -amar

  5. #5
    Join Date
    Nov 2000
    Location
    Baltimore, MD USA
    Posts
    1,339
    Unfortunately, I cannot get to metalink - can you give me the basic idea of the issue?

    Thanks,

    - Chris
    Christopher R. Long
    ChrisRLong@HotMail.Com
    But that's just my opinion. I could be wrong

  6. #6
    Join Date
    Mar 2001
    Posts
    314
    Suggestion from metalink:


    Solution Description
    -------------------- Upgrade to the latest ODBC driver and enable the option 'Disable MTS
    support' in the DSN configuration. To do this, perform the following steps: 1. Click Start -> Settings -> Control Panel -> ODBC Administrator
    2. Select the DSN you are using, then click the Configure button.
    3. You should see the 'Disable MTS support 'option listed in the 'Workarounds'
    section. If you do not see this option, you are probably not on the latest
    version.
    4. It is sometimes necessary to either drop and recreate the DSN and/or
    table link in MSAccess, as MSAccess appears to cache DSN settings.


    -amar

  7. #7
    Join Date
    Sep 2001
    Location
    Mexico
    Posts
    93
    I had the same problem calling an Oracle's store procedure from ASP.
    The soulution was to "Disable the MTS" option in the ODBC.

    Thank you very much!

    Regards and congratulations.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width