TOAD 7.1.7.21 gives 'Invalid variant operation'
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: TOAD 7.1.7.21 gives 'Invalid variant operation'

  1. #1
    Join Date
    Dec 2000
    Posts
    43

    Question TOAD 7.1.7.21 gives 'Invalid variant operation'

    Subj, when trying to look at table script in TOAD`s schema browser. Oracle version is 9.2.0.2 64 bit.

    The best part is - it`s able to show some tables but on the majority of them gives this error message and it does not matter if I was connected as schema owner or as SYSTEM. And I cannot get any correlation or specific rule how does it happen. I`m pretty much sure that dictionary is OK and there is no invalid objects in this database.

    Did anybody get something like this before? Is it bug or feature?
    What would be a solution?

    I saw this message in 7.1 Toad bug fix list, but it was related to tablespace alter function, as far as I remember, and I didn`t see anything like this yet and it looks like google gave nothing as well.

  2. #2
    Join Date
    Dec 2000
    Posts
    43

    Re: TOAD 7.1.7.21 gives 'Invalid variant operation'

    Originally posted by utkinpol
    Subj, when trying to look at table script in TOAD`s schema browser. Oracle version is 9.2.0.2 64 bit.

    The best part is - it`s able to show some tables but on the majority of them gives this error message and it does not matter if I was connected as schema owner or as SYSTEM. And I cannot get any correlation or specific rule how does it happen. I`m pretty much sure that dictionary is OK and there is no invalid objects in this database.

    Did anybody get something like this before? Is it bug or feature?
    What would be a solution?

    I saw this message in 7.1 Toad bug fix list, but it was related to tablespace alter function, as far as I remember, and I didn`t see anything like this yet and it looks like google gave nothing as well.
    OK, it dies if you check the 'storage' box. It`s not important, but what IS important - this thing dies as well if you try to do
    'Database-Export-Table Scripts' operation and this really sucks.

    Does anybody know what would be a workaround?

  3. #3
    Join Date
    Dec 2000
    Posts
    43

    Re: Re: TOAD 7.1.7.21 gives 'Invalid variant operation'

    Originally posted by utkinpol
    OK, it dies if you check the 'storage' box. It`s not important, but what IS important - this thing dies as well if you try to do
    'Database-Export-Table Scripts' operation and this really sucks.

    Does anybody know what would be a workaround?
    OK, workaround found - TOAD 7.4.0.3...

  4. #4
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    I wouldn't expect too many responses since you ticked off two of the most knowlegeable people on this site... http://www.dbasupport.com/forums/sho...8&pagenumber=3
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  5. #5
    Join Date
    Jul 2005
    Posts
    2

    Invalid variant operation

    All you have to do is, in the schema browser UNCHECK the storage checkbox.

    Regards

    Jude Patrick
    Megasoft Ltd.

  6. #6
    Join Date
    Jul 2005
    Posts
    2
    For Export - Table Script all you need to do is UNCHECK "include table space info"

  7. #7
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    umm no offence, but I doubt he is checking it after 2 years

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width