Hi all,
I'm using Oracle Server (Windows NT)
and Forms
This is my problem:
I have a base table block with a text item
that is formatted like: Date 'DD.MM.RR', property max length is set to 8.
If I:
1. query a certain recordset, the Data is displayed just fine.
2. navigate to my text item via Tab. The cursor is in the text item and there is still the old valid date(8 characters,NO blanks) being displayed and it is marked as selected.
3.now enter a new Date into my textfield(overwriting the old one), it allows just 6 characters to be entered(like '31.12.').
I then have to press 'del' twice to be able to complete the date(like '31.12.02').

the default value property of the item is set to NULL, so this is not the problem.
I tried to launch a message each 5 seconds to check whether there are any blanks or tabs in the text item but to_char(:my_textitem) returns -0 as the value of the item is not (yet)
a valid date.
I also tried all this with a completely new Form with just one base table block and just two items(a product number to be able to query a certain record and my date text item). Same problem.
with 10 char Max Length the problem basically stays the same as well.

Any ideas what's going on here and how to handle it ?
thanx in advance
Horst Borscht