Listener Problem
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 8 of 8

Thread: Listener Problem

  1. #1
    Join Date
    Nov 2002
    Posts
    115

    Listener Problem

    Hi ,
    I am getting following error when I try to config Net8 in 9i .
    Can any one help? Why the Listener has n't been started ?


    Initializing first test to use userid: scott, password: tiger
    Attempting to connect using userid: scott
    The test did not succeed.
    ORA-12541: TNS:no listener


    LISTENER.ORA
    ==============

    LISTDWHG =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC0))
    )
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = 172.16.4.155)(PORT = 1521))
    )
    )

    SID_LIST_LISTDWHG =
    (SID_LIST =
    (SID_DESC =
    (GLOBAL_DBNAME = DWHG.WORLD)
    (ORACLE_HOME = d:\ora9i)
    (SID_NAME = DWHG)
    )
    (SID_DESC =
    (PROGRAM = extproc)
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = d:\ora9i)
    )

    TNSNAMES.ORA
    ===============
    DWHGORA.WORLD =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = 172.16.4.155)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = DWHG)
    )
    )

    SQLNET.ORA
    ===============

    SQLNET.AUTHENTICATION_SERVICES= (NTS)
    SQLNET.EXPIRE_TIME = 0

    NAMES.DEFAULT_DOMAIN = WORLD
    NAMES.DIRECTORY_PATH= (TNSNAMES, HOSTNAME)
    Prasad

  2. #2
    Join Date
    Aug 2001
    Location
    Waterloo, On
    Posts
    547
    Did you do lsnrctl start??

    Raminder Singh

    Oracle Certified DBA: Oracle 8i, 9i


    Mail me at raminderahluwalia@rediffmail.com.

  3. #3
    Join Date
    Oct 2000
    Location
    Germany
    Posts
    1,185
    The commands start, stop, and status from the lsnrctl command line assume the default name of "listener". In your case, the listener name is "LISTDWHG ".

    Try this

    > lsnrctl

    lsnrctl> start LISTDWHG

    followed by

    lsnrctl> status LISTDWHG
    David Knight
    OCP DBA 8i, 9i, 10g

  4. #4
    Join Date
    Nov 2002
    Posts
    115
    Raminder,

    I have tried already. But I couldn't get the solution.

    Thanx
    Prasad

  5. #5
    Join Date
    Dec 2002
    Location
    Bangalore ( India )
    Posts
    2,434
    Prasad:

    After u giv

    Lsnrctl>Start

    Check in SERVICES if its started or if its stopping due previlages(I mean Local System Previlage to start a service).

    Abhay.

  6. #6
    Join Date
    Aug 2001
    Location
    Waterloo, On
    Posts
    547
    Ok. Your listener name is not listener. Do as suggested by the knight (in shining...you know what)

    Raminder Singh

    Oracle Certified DBA: Oracle 8i, 9i


    Mail me at raminderahluwalia@rediffmail.com.

  7. #7
    Join Date
    May 2000
    Location
    ATLANTA, GA, USA
    Posts
    3,136
    In init.ora add an entry, local_listenenr if LISTENER is not the name, you used.

  8. #8
    Join Date
    May 2002
    Posts
    2,645
    Aside from other problems you are going to face, is d:\ora9i the path to ORACLE_HOME? Or is it more like d:\ora9i\oracle?

    Is your host IP address correct? Can you ping that address?

    Have you tried using an assistant? Or do you want to keep trying this by hand?

    Other Info:

    sqlnet.ora and tnsnames.ora file relationship

    The NAMES.DIRECTORY_PATH parameter in sqlnet.ora can be commented out (or not even included) because the order shown below is the default search order for names resolution in Net8 (Oracle Net for 9i).

    The service name equals the instance name + the default domain. If you are trying to connect to an instance running on your machine, you don't need to have the listener running. Net8 spawns a bequeath session, which is the same as a dedicated server process. You DO need to have the ORACLE_SID environment variable set to the name of the database on your machine you are trying to connect to. If you set the NAMES.DEFAULT_DOMAIN parameter in sqlnet.ora (e.g., company.com), then Oracle will append company.com to the net service name in the connect string (the net service name is the name following the @ sign). After that, Oracle will look for an address of name_you_used.company.com. If your database names are not named that way in the tnsnames.ora file, you will see a TNS- or ORA-12154 error ("could not resolve service name"). Other errors are possible too.

    NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)

    If you are using NAMES.DEFAULT_DOMAIN, the value should match the domain name of your local environment. For example, assume your domain name is company.com. A fully qualified net service name for a database named kfm would be kfm.company.com. If you are connecting remotely (and you can do this on the server by going thru the
    network), the connect descriptor is username/password@kfm. What Oracle Net8 does is take "kfm" and add the value for NAMES.DEFAULT_DOMAIN to it (i.e., kfm.company.com) and then looks for an entry of kfm.company.com in your tnsnames.ora file. If Net8 does not see kfm.company.com in the file, you get an error.

    If you don't use a default domain name, leave that parameter commented out or just delete the line in sqlnet.ora. That way, when you use username/password@kfm, Net8 simply looks for a stanza begining with "kfm" in the tnsnames.ora file.

    NAMES.DEFAULT_DOMAIN = company.com

    Note: If you are using the Database Configuration Assistant (usually see this when installing the RDBMS software at the point where the seed database is created), don't use a hyphen in the domain name because the assistant won't recognize a hyphen as a valid character. You can go back later and manually edit sqlnet.ora and tnsnames.ora
    to add the hyphen in the domain name.

    Don't even bother using "WORLD" as a default_domain name. Get rid of it. Don't need it.
    Last edited by stecal; 12-26-2002 at 03:52 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width