Failed to start listener
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: Failed to start listener

Hybrid View

  1. #1
    Join Date
    Apr 2002
    Posts
    73

    Failed to start listener

    I got the following message when I start the listener in Window 2000:
    Failed to start service, error 1058.
    TNS-12536: TNS: operatioin would block
    TNS-12560: TNS: protocol adapter error
    TNS-00506: operation would block
    32-bit windows error: 997: unknow error


    My listener file:
    # LISTENER.ORA Network Configuration File: D:\oracle\ora81\network\admin\listener.ora
    # Generated by Oracle configuration tools.

    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = B2E-PERFTEST)(PORT = 1521))
    )
    )
    )

    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = B2EOPT)
    (ORACLE_HOME = D:\oracle\ora81)
    (PROGRAM = extproc)
    )
    (SID_DESC =
    (GLOBAL_DBNAME = B2EOPT)
    (ORACLE_HOME = D:\oracle\ora81)
    (SID_NAME = B2EOPT)
    )
    )
    connect_timeout_listener=10
    trace_level_listener_listener=off

  2. #2
    Join Date
    May 2002
    Posts
    2,645
    A Windows bug is one reason per MetaLink. Here is one solution:

    CODE CONNECT_TIMEOUT_LISTENER = 30 IN LISTENER.ORA

    Solution Description:
    =====================
    Code CONNECTION_TIMEOUT_LISTENER = 30 in listener.ora file. This allows more connections and resolves the problem.

  3. #3
    Join Date
    Apr 2002
    Posts
    73
    Thanks for your response.
    I updated the CONNECT_TIMEOUT_LISTENER = 30 IN LISTENER.ORA and rebooted the server, but still got the same error message.

  4. #4
    Join Date
    Aug 2000
    Location
    Chicago IL
    Posts
    586
    Blu. you dont have to reboot your server everytime you change your listener.ora. you just have to bounce the listener..

    Q1. was the listener working before?
    Q2. Did you make changes to permissions?
    "High Salaries = Happiness = Project Success."

  5. #5
    Join Date
    Aug 2000
    Location
    Chicago IL
    Posts
    586
    1. first check if u can connect to the database locally, ( NOT FROM THE CLIENT). try c:\sqlplus username/password2. Ensure that the LOCAL and TWO_TASK environment variable are not defined 3. The database installation may have failed to make a registry entry for ORACLE_SID. Try adding the string value ORACLE_SID and modifying its data to the proper sid name. Verify that ORACLE_HOME and ORACLE_SID are entered into the registry properly in HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOMEx. The bequeath adapter attempts to connect to the default ORACLE_SID in the default ORACLE_HOME.
    "High Salaries = Happiness = Project Success."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width