sqlplus connection
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: sqlplus connection

  1. #1
    Join Date
    Oct 2002
    Location
    Bangalore,India
    Posts
    32

    sqlplus connection

    kind attention SAMEER

    I have performed all the 3 steps continusoulsy on the Unix Server as u can see from the timings. why I am getting errors in step 1 & step 2


    STEP 1:

    au19ora:GTRN> sqlplus "sys/sysau19@utl1 as sysdba"

    SQL*Plus: Release 3.3.3.0.0 - Production on Thu Nov 28 16:35:42 2002

    Copyright (c) Oracle Corporation 1979, 1996. All rights reserved.

    ERROR: ORA-12154: TNS:could not resolve service name



    STEP 2:

    Enter user-name: au19ora:GTRN> sqlplus "sys@utl1 as sysdba"

    SQL*Plus: Release 3.3.3.0.0 - Production on Thu Nov 28 16:36:02 2002

    Copyright (c) Oracle Corporation 1979, 1996. All rights reserved.

    Enter password:

    ERROR: ORA-12154: TNS:could not resolve service name



    STEP 3:

    Enter user-name: au19ora:GTRN> > sqlplus sys/sysau19@utl1

    SQL*Plus: Release 3.3.3.0.0 - Production on Thu Nov 28 16:36:23 2002

    Copyright (c) Oracle Corporation 1979, 1996. All rights reserved.

    Connected to:

    Oracle8 Enterprise Edition Release 8.0.5.2.2 - Production

    With the Partitioning and Objects options

    PL/SQL Release 8.0.5.2.1 - Production

    SQL>

  2. #2
    Join Date
    Sep 2001
    Location
    Düsseldorf, Germany.
    Posts
    588
    do you have multiple tnsnames.ora??

    As I suggested in the other post about "SYSDBA" and password file.. have you tried that?

  3. #3
    Join Date
    Oct 2002
    Location
    Bangalore,India
    Posts
    32

    sysdba

    Sameer,

    In the earleir post the problem has arisen when I was connecting from a sql window from my workstation, but in this case all the commands have been used on the unix box.

    for the earlier post I used orapwd utility in /usr/home/oracle/admin/utl1/pfile path a file named pwdUTL1.ora and created a link to the dbs directory. the file and link are created successfully. but when I am opening the database I am getting the following error:
    au19ora:UTL1> orapwd file=/usr/home/oracle/admin/utl1/UTL1pwd.ora entries=5 password=bt
    au19ora:UTL1> ln -s /usr/home/oracle/admin/utl1/UTL1pwd.ora /usr/home/oracle/product/8.0.5.2.2
    au19ora:UTL1> db

    Oracle Server Manager Release 3.0.5.0.0 - Production

    (c) Copyright 1997, Oracle Corporation. All Rights Reserved.

    Oracle8 Enterprise Edition Release 8.0.5.2.2 - Production
    With the Partitioning and Objects options
    PL/SQL Release 8.0.5.2.1 - Production

    SVRMGR> connect internal
    Connected.
    SVRMGR> startup
    ORACLE instance started.
    Total System Global Area 6414424 bytes
    Fixed Size 49240 bytes
    Variable Size 4243456 bytes
    Database Buffers 2048000 bytes
    Redo Buffers 73728 bytes
    ORA-01991: invalid password file '/usr/home/oracle/product/8.0.5.2.2/dbs/orapw'

  4. #4
    Join Date
    Sep 2001
    Location
    Düsseldorf, Germany.
    Posts
    588
    ORA-01991: invalid password file '/usr/home/oracle/product/8.0.5.2.2/dbs/orapw'
    It is pointing to someother password file... There must be a file called "orapw$ORACLE_SID" in /usr/home/oracle/product/8.0.5.2.2/dbs/ .. why don't you create password file there or rename the old one... Check if there is password file called orapw$ORACLE_SID in /usr/home/oracle/product/8.0.5.2.2/dbs/

  5. #5
    Join Date
    Oct 2002
    Location
    Bangalore,India
    Posts
    32

    sysdba

    Sameer,

    I will check up and will update with the details. But, meanwhile can you explain the present post wherein I still get the error when I am using all the steps on the SERVER itself.

    Thanks

  6. #6
    Join Date
    Nov 2002
    Location
    Dublin, Ireland
    Posts
    133

    Wink

    Tharakab,

    When you create the password file you don't have to specify .ora.
    Your password file should start with orapw
    try like this:
    orapwd file=/usr/home/oracle/product/8.0.5.2.2/dbs/orapwUTL1 password=bt entries=5

    Giani

  7. #7
    Join Date
    Sep 2001
    Location
    Düsseldorf, Germany.
    Posts
    588
    I guess all those errors are because you are trying to connect as 'sysdba' or as you said in one of the other post that you have several databases on one box, In that case what is default $ORACLE_SID.. The error points to that.. Do you have multiple tnsnames.ora??

    Well the other suggestion is name password file as suggested...

  8. #8
    Join Date
    Oct 2002
    Location
    Bangalore,India
    Posts
    32

    Thumbs up

    GIANI/samir,

    You are right. when I removed the suffix .ora and created i am able to successfully open the database and able to connect to database also from the client (i.e. sqlplus window). Bit I have to check up if I can startup/shutdown from my client.

    Thanks for both of you. I will get back to you guys if I have any problem.

  9. #9
    Join Date
    Oct 2002
    Location
    Bangalore,India
    Posts
    32
    Samir,

    inspite of creating password file when I am connecting with the new password I am getting the below error for the qn. mentioned in steps 1,2,3 above.

    Clue: GTRN has oracle_HOME 7.3, whereas UTL1 has ORACLE_HOME 8.0.5.2.2.
    u have asked me If I have 2 tnsnames.ora files. there are 2 but on different oracle homes. If that is so step 3 should not work. CAN U EXPLAIN


    au19ora:GTRN> sqlplus "sys/bt@utl1 as sysdba"

    SQL*Plus: Release 3.3.3.0.0 - Production on Fri Nov 29 23:39:22 2002

    Copyright (c) Oracle Corporation 1979, 1996. All rights reserved.

    ERROR: ORA-12154: TNS:could not resolve service name

  10. #10
    Join Date
    Oct 2002
    Location
    Bangalore,India
    Posts
    32

    sysdba

    samir,

    In continuation to the qn. after the creation of password file on the server after connecting to server manager on the server when I issue connect internal it should ask for a password since remote_login_password_file=exclusive, instead it is getting connected without password. I tried using svrmgr>connect / as sysdba. even for this it is connecting and not asking password

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width