TNS - Couln't resolve service name
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: TNS - Couln't resolve service name

  1. #1
    Join Date
    Nov 2000
    Posts
    101

    TNS - Couln't resolve service name

    Dear Friends,

    I have configured tnsnames through netconfiguration assistant.
    The test suceeds.

    My listener is up, i am able to work in GUI mode applications like "oemapp dbastudio". My O/S is IBM-AIX.

    But, when i connect through command line it gives.

    ORA-12154: TNS:could not resolve service name


    Could any one help me on this.


    Thanks
    gandhi
    OCP8-DBA

  2. #2
    Join Date
    Dec 2001
    Location
    SAN FRANCISCO, CA
    Posts
    306
    just go to network directorty \ admin\tnsnames.ora file and see the service name that has been generated.
    put the exact service name as string name.

    I think it should work now.
    Eat , Drink & Enjoy life -

    pravin_kini@hotmail.com

  3. #3
    Join Date
    Oct 2002
    Location
    Singapore
    Posts
    16
    Change the service_name to SID and try.
    Never Ever Give Up!

  4. #4
    Join Date
    Nov 2000
    Posts
    101
    Hi

    I changed the Service name as SID and tried , still it fails.


    Could u give me some thought on this.


    gandhi
    OCP8-DBA

  5. #5
    Join Date
    Jan 2002
    Location
    Netherlands
    Posts
    1,591
    How do you try to connect in the cmd line?
    Is it the only instance?
    Tarry Singh
    I'm a JOLE(JavaOracleLinuxEnthusiast)
    TarryBlogging
    --- Everything was meant to be---

  6. #6
    Join Date
    Nov 2000
    Posts
    101
    Hi Tarry,

    Now, the problem is solved by setting TNS_ADMIN parameter

    I have two instances, i could connect to both the instances.



    Thanks
    gandhi

  7. #7
    Join Date
    Sep 2001
    Location
    Mexico
    Posts
    93
    Recently I had a similar problem in Oracle 8i on AIX. Other computers can connect to the database throught a service, but locally the database computer cannot connect itselft via a service.

    The problem was solved modifying the corrupted sqlnet.ora file in the database computer. Now it can connect to the local service without problems.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width