ORA 4031 error, urgent
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: ORA 4031 error, urgent

Hybrid View

  1. #1
    Join Date
    Apr 2002
    Posts
    291

    ORA 4031 error, urgent

    Hi all,
    I'm getting ORA-4031 error :unable to allocate 6666240 bytes of shared memory("large pool","object","hash-join subh") error.

    My current shared_pool_size is 220 MB. I want to set it to 320 MB. I'm running oracle 9i Rel 2 on linux 7.2 .C Can i adjust this parameter dynamically, then the DB is up and running , if yes, how can i do that. Can any help me with the steps please. I want to adjust the shared_pool_reserve_size also. Please let me know the steps asap, as all my users can't connect and are waiting. or else DO i need to restart my DB after setting in init.ora file?

    Thanks in advance
    PNRDBA

  2. #2
    Join Date
    Sep 2002
    Location
    England
    Posts
    7,333
    that would be ure kernel parameters in /etc/system which need bumping up, shared memory and semaphores

  3. #3
    Join Date
    Sep 2001
    Location
    Düsseldorf, Germany.
    Posts
    588
    Have you tried setting large_pool_size. Don't just go on increasing size of shared_pool_size.

    Set PARALLEL_AUTOMATIC_TUNING to true even though you are not going to use any parallel clause. Because of this Oracle will automatically calculate value for large_pool_size.
    Last edited by Sameer; 11-28-2002 at 07:02 AM.

  4. #4
    Join Date
    Apr 2002
    Posts
    291
    thanks for your immediate response, even though i set my shared_pool_size to 320Mb, its not working. My large_pool_size is 10MB. my DB version is 9.0.1.4.0, Do i need to set the parameter parallel_automatic_tuning=true in my init.ora? and what about the large_pool_size.

    thanks
    PNRDBA

  5. #5
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    are you using MTS

  6. #6
    Join Date
    Sep 2001
    Location
    Düsseldorf, Germany.
    Posts
    588
    Just set parallel_automatic_tuning to true and do not set the value for large_poo_size... Oracle will automatically calculate value for large_pool_size...

  7. #7
    Join Date
    Apr 2002
    Posts
    291
    Pando,
    we are not using MTS.

    Sameer, i set the parallel_automatic_tuning=true in my init.ora file and restarted the DB, and still giving the same problem.

    thanks
    PNRDBA

  8. #8
    Join Date
    Sep 2001
    Location
    Düsseldorf, Germany.
    Posts
    588
    If not MTS, then it won't be of much use.. Sorry I forgot to ask you before.. what are you other settings?.. what is the value for db_cache_size?.., Are you pinning large objects?
    Last edited by Sameer; 11-28-2002 at 07:27 AM.

  9. #9
    Join Date
    Apr 2002
    Posts
    291
    my java_pool_size is set to 0. Do i need to increase?? please help me, all my users are waiting

    thanks
    PNRDBA

  10. #10
    Join Date
    Sep 2001
    Location
    Düsseldorf, Germany.
    Posts
    588
    Is java application using database, then set it to 50M+ (atleast)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width