Get_application_property(username).
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: Get_application_property(username).

Hybrid View

  1. #1
    Join Date
    Jul 2002
    Posts
    24

    Question Get_application_property(username).

    I put the following code into "When_New_Form_Instance" at Module level but its not working.

    DECLARE
    UN VARCHAR2(80);
    PW VARCHAR2(80);
    CN VARCHAR2(80);

    BEGIN
    UN := GET_APPLICATION_PROPERTY(USERNAME);
    PW := GET_APPLICATION_PROPERTY(PASSWORD);
    CN := GET_APPLICATION_PROPERTY(CONNECT_STRING);

    if UN = 'Peter' then
    set_item_property('BlockName.ItemName',visible,property_false);
    END IF;
    END;


    Whats wrong with that code. Where should i put it?
    Why GET_APPLICATION_PROPERTY(USERNAME) is not working (can't get a username)?

    Any help please?
    Thank you.

  2. #2
    Join Date
    May 2002
    Posts
    2,645
    What is not working? Are you getting an error code, or no data returned? If nothing returned, try using PETER instead of Peter. If you create a user, the statement can be all lowercase. But, when you want to query for the username in dba_users, for example, you have to query by using all uppercase. I would expect the built-in to act the same way with respect to the username.

  3. #3
    Join Date
    Jul 2002
    Posts
    24
    Thank you Stecal,

    Its working now. It was uppercase proplem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width