Can not login to database as local connetion as not oracle user - Page 2
DBAsupport.com Forums - Powered by vBulletin
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28

Thread: Can not login to database as local connetion as not oracle user

  1. #11
    Join Date
    Oct 2002
    Posts
    14
    I am usinf folwing OS :

    SunOS home 5.7 Generic_106541-23 sun4u sparc SUNW,UltraSPARC-IIi-cEngine

    thx
    Vivek


  2. #12
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    echo $TWO_TASK

  3. #13
    Join Date
    Oct 2002
    Posts
    14
    If I set TWO_TASK then it will work because then it uses Oracle sqlnet v8. I want to connect to database without giving service name.

    Vivek

  4. #14
    Join Date
    Oct 2002
    Posts
    23

    Also

    I should have asked this before. OOPS You do have an interesting problem. I hope we can help you fix.

    What Oracle Version are you running on your server?

    Also type the following commands and show us the output:
    1) Info about Shared memory: ipcs -A
    2) What is your current swap: swap -s
    3) How many processors:
    /usr/sbin/psrinfo -v |grep "Status of processor"|wc -l
    4) Top 6 process hogs: ps -ef|sort +6| tail
    5) Display Ram Size: prtconf| grep -i mem

    Check your Alert log for ORA- errors. Are there any? If so what?

    Check your /var/adm/messages file for unusual errors.

    Just a few troubleshooting ideas. Have you tried Metalink?

    Michellea
    "Live Life to the Fullest"

  5. #15
    Join Date
    Oct 2002
    Posts
    23

    Forget the last reply

    Forget the last reply. It sounds like the real issue is that you do not want to use net8.

    Just a question: Why would you not want to use net8?

    Michellea
    "Live Life to the Fullest"

  6. #16
    Join Date
    Oct 2002
    Posts
    14
    Well it is not that I don't want to use Net8.

    I just want to know why it is not working? It is a simple local connection. It works in my all other servers with same database.ipcs -A
    IPC status from as of Wed Oct 9 14:56:32 PDT 2002
    Message Queue facility inactive.
    T ID KEY MODE OWNER GROUP CREATOR CGROUP NATTCH SEGSZ CPID LPID ATIME DTIME CTIME ISMATTCH
    Shared Memory:
    m 0 0x500004a4 --rw-r--r-- root root root root 1 68 210 210 16:53:25 16:53:25 16:53:25 1
    m 6001 0xc020b8c0 --rw------- oracle dba oracle dba 7 375144448 6124 6200 11:25:45 11:26:01 16:28:144294967292
    T ID KEY MODE OWNER GROUP CREATOR CGROUP NSEMS OTIME CTIME
    Semaphores:
    s 7536640 0xf16a3764 --ra------- oracle dba oracle dba 304 4:30:20 16:28:16
    vivek


  7. #17
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Can you just do
    Code:
      tnsping servicename
    Tell us what the result? I'm also curious to see your sqlnet.ora file settings.

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  8. #18
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    Originally posted by vdeo
    If I set TWO_TASK then it will work because then it uses Oracle sqlnet v8. I want to connect to database without giving service name.

    Vivek
    I am not asking you to use TWO_TASK, I was asking what's your TWO_TASK value

  9. #19
    Join Date
    Oct 2002
    Posts
    23

    Permissions

    Look at the permissions on your output:
    __________________________________________________________
    I just want to know why it is not working? It is a simple local connection. It works in my all other servers with same database.ipcs -A
    IPC status from as of Wed Oct 9 14:56:32 PDT 2002
    Message Queue facility inactive.
    T ID KEY MODE OWNER GROUP CREATOR CGROUP NATTCH SEGSZ CPID LPID ATIME DTIME CTIME ISMATTCH
    Shared Memory:
    m 0 0x500004a4 --rw-r--r-- root root root root 1 68 210 210 16:53:25 16:53:25 16:53:25 1
    m 6001 0xc020b8c0 --rw------- oracle dba oracle dba 7 375144448 6124 6200 11:25:45 11:26:01 16:28:144294967292
    T ID KEY MODE OWNER GROUP CREATOR CGROUP NSEMS OTIME CTIME
    Semaphores:
    s 7536640 0xf16a3764 --ra------- oracle dba oracle dba 304 4:30:20 16:28:16
    ____________________________________________________________

    The Oracle file should give rw to oracle and the group dba, but your output shows that it does not. Also Semaphores gives ra to oracle only, it should be oracle and dba.

    Looks like a permission problem. My output looks like this:
    /export/home/>ipcs -A
    IPC status from as of Thu Oct 10 09:06:23 MDT 2002
    T ID KEY MODE OWNER GROUP CREATOR CGROUP CBYTES QNUM QBYTES LSPID LRPID STIME RTIME CTIME
    Message Queues:
    T ID KEY MODE OWNER GROUP CREATOR CGROUP NATTCH SEGSZ CPID LPID ATIME DTIME CTIME I
    SMATTCH
    Shared Memory:
    m 0 0x50005f4f --rw-r--r-- root root root root 1 4 259 259 10:52:44 10:52:44 10:52:44
    0
    m 101 0xa53ab7ac --rw-rw---- oracle dba oracle dba 10 160915456 461 4965 8:12:27 8:12:27 15:15:39
    10

    T ID KEY MODE OWNER GROUP CREATOR CGROUP NSEMS OTIME CTIME
    Semaphores:
    s 458752 0xe035d35c --ra-ra---- oracle dba oracle dba 104 8:19:32 15:15:40
    s 720897 0x42aab180 --ra-ra---- oracle dba

    I know you said you checked the file permissions, but could you check again? Check $ORACLE_HOME/dba/init.ora, ....
    Actually I would go through all of $ORACLE_HOME and check the permissions on all the files. Check $ORACLE_BASE/admin/sid files also.

    Good Luck -


    Michellea
    "Live Life to the Fullest"

  10. #20
    Join Date
    Oct 2002
    Posts
    14
    Hi I checked my other servers and there also I have same sepasphore permossion. I don't have any problem there.

    vivek

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width