Primary Database Setting - Standby Database
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Primary Database Setting - Standby Database

  1. #1
    Join Date
    Oct 2000
    Posts
    250
    Hi All,
    I have problem to startup the primary database for my standby database setup. Both Primary and Standby are the same host.

    Primary - initmydb.ora
    log_archive_start = true
    log_archive_format = %%ORACLE_SID%%T%TS%S.ARC
    log_archive_dest_1="d:\oracle\oradata\mydb\archive\"
    log_archive_dest_state_1=ENABLE
    log_archive_dest_2="SERVICE=STBY MANDATORY REOPEN=30"
    log_archive_dest_state_2=ENABLE

    Standby - initstby.ora
    log_archive_start = true
    log_archive_format = %%ORACLE_SID%%T%TS%S.ARC
    standby_archive_dest="d:\oracle\oradata\stby\archive"
    db_file_name_convert="d:\oracle\oradata\mydb","d:\oracle\oradata\stby"
    log_file_name_convert="d:\oracle\oradata\mydb\archive","d:\oracle\oradata\stby\archive"
    lock_name_space=STBY


    I can managed to startup the secondary with nomount mode and startby database successfully but not the primary database.

    I have following error message when I start primary DB :
    SQL> startup pfile=d:\oracle\admin\mydb\pfile\initmydb.ora
    LRM-00101: unknown parameter name 'SERVICE'
    LRM-00101: unknown parameter name 'SERVICE'
    LRM-00111: no closing quote for value '30"
    log_ar'
    ORA-01078: failure in processing system parameters


    Thanks for any feedback given.

  2. #2
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,448
    log_archive_dest_1 = "LOCATION=/archive1"
    log_archive_dest_2 = "SERVICE=standby_db1"

    I think you log_archive_dest_1 syntax is wrong

  3. #3
    Join Date
    Oct 2000
    Posts
    250
    Thanks for the reply but I still has error

    SQL> startup pfile=D:\oracle\admin\mydb\pfile\initmydb.ora
    LRM-00111: no closing quote for value 'STBY"
    log_'
    ORA-01078: failure in processing system parameters

    I had change as follow
    log_archive_start = true
    log_archive_max_processes = 10
    log_archive_format = %%ORACLE_SID%%T%TS%S.ARC
    # log_archive_dest=d:\oracle\oradata\mydb\archive\
    log_archive_dest_1="LOCATION=d:\oracle\oradata\mydb\archive\"
    log_archive_dest_state_1=ENABLE
    log_archive_dest_2="SERVICE=STBY"
    log_archive_dest_state_2=ENABLE

  4. #4
    Join Date
    Dec 2000
    Location
    Ljubljana, Slovenia
    Posts
    4,439
    Originally posted by ckwan
    log_archive_dest_2="SERVICE=STBY"
    Try changing the above into:

    log_archive_dest_2='SERVICE=STBY'

    Use single quotes instead of double quotes.
    Jurij Modic
    ASCII a stupid question, get a stupid ANSI
    24 hours in a day .... 24 beer in a case .... coincidence?

  5. #5
    Join Date
    Oct 2000
    Posts
    250
    After I changed the log_archive_dest_2 = 'SERVICE=STBY'

    LRM-00111: no closing quote for value 'LOCATION=d'
    LRM-00113: error when processing file 'd:\oracle\admin\mydb\pfile\initmydb.ora'
    ORA-01078: failure in processing system parameters

    I get this error then I also modify the log_archive_dest_1
    to become log_archive_dest_1 = 'LOCATION=d:\oracle\oradata\mydb\archive\'

    I get another error

    LRM-00101: unknown parameter name 'SERVICE'
    ORA-01078: failure in processing system parameters

    it seems quite 'challenge' to setup the standby database.

  6. #6
    Join Date
    Dec 2000
    Location
    Ljubljana, Slovenia
    Posts
    4,439
    Originally posted by ckwan
    I get this error then I also modify the log_archive_dest_1
    to become log_archive_dest_1 = 'LOCATION=d:\oracle\oradata\mydb\archive\'
    I belive that last backslash is the culprit of all your troubles! It shouldn't be there. I belive Oracle is interpreting it as an escape character, so the following quote character does not act as an enclosing quote. So Oracle is interpreting path for the LOCATION way down to the next quote chaqracter, which is before SERVICE keyword in log_archive_dest_2 parameter. So it is interpreting the word SERVICE as the next parameter, which of course is unknown and invalid as a parameter.

    Remove that backslash and let us know if it has solved your problem.
    Originally posted by ckwan
    it seems quite 'challenge' to setup the standby database
    I've setup standby at least 10 times and never had any major problems .
    Jurij Modic
    ASCII a stupid question, get a stupid ANSI
    24 hours in a day .... 24 beer in a case .... coincidence?

  7. #7
    Join Date
    Oct 2000
    Posts
    250
    Thanks for the prompt reply.

    After I removed the black slash (\) I have following error

    SQL> startup
    ORA-00439: feature not enabled: Managed Standby


  8. #8
    Join Date
    Jan 2001
    Posts
    50
    guess your
    log_archive_dest_1 = 'LOCATION=d:\oracle\oradata\mydb\archive\'

    should
    be
    log_archive_dest_1 = 'LOCATION=d:\oracle\oradata\mydb\archive'

    ie there shd be no "\" at the end of path ....
    Aniruddha Gupta

  9. #9
    Join Date
    Dec 2000
    Location
    Ljubljana, Slovenia
    Posts
    4,439
    Originally posted by ckwan
    SQL> startup
    ORA-00439: feature not enabled: Managed Standby
    This is becoming a bit teasing . My guess is you are using Oracle Standard Edition. To use LOG_ARCHIVE_DEST_n parameters (in other words, to implement managed standby configuration) you need Enterprise Edition.

    Can you provide details about the database release and type (Enterprise, Standard, Personal) you are using?
    Jurij Modic
    ASCII a stupid question, get a stupid ANSI
    24 hours in a day .... 24 beer in a case .... coincidence?

  10. #10
    Join Date
    Oct 2000
    Posts
    250
    I checked my installer is an Enterprise Edition. Is there any other faster way to check the Edition I have currently ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width