How would I increase ulimit parameters
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: How would I increase ulimit parameters

  1. #1
    Join Date
    Oct 2000
    Posts
    449
    Hello DBAs:

    We have a datafile block corruption error when trying to create an index for a table.

    We created this table, pumped in rows and tried creating an index when it errors with ora-01114 and 27063.. Increased tablesize (new datafile, extended datafile and so on..)Tried all options, such as analyze on the table and it fails. Moved the same table to different tablespace and still it fails to analyze completely, but can estimate to 15-20%.. One of our dba's suspect due to ulimit not set as unlimited for all the options..

    oracle@CG_JDA1:/home/oracle_> ulimit -a
    time(seconds) unlimited
    file(blocks) unlimited
    data(kbytes) 131072
    stack(kbytes) 32768
    memory(kbytes) 32768
    coredump(blocks) 2097151
    nofiles(descriptors) 2000

    How can I set all these to unlimited.. Should I login as root and do it ??

    Secondly, how will this solve?

    I am unable to gain access to metalink, today..

    Thanks, ST2000

  2. #2
    Join Date
    Apr 2001
    Posts
    21
    You can check the man page on ulimit. What I normally do is edit the /etc/security/limits file and set value to -1 for all parameters. These changes will not take effect for the user until they log off and back onto the system.

    dkm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width