Database link does not work since something is changed
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Database link does not work since something is changed

Hybrid View

  1. #1
    Join Date
    Sep 2002
    Posts
    2

    Angry

    Hi all,

    I have a question regarding Database link with tnsnames.ora.

    I created a db link a few weeks ago. It worked fine.
    Just one day, it failed, the error message saying:
    Couldn't find hostname, or host doesn't exist.

    I could link to remote DB side by typing connect syuan/***@remote_db.

    Only Db link didn't work. Later I changed the host to ip address instead of host name. Then everything works fine.

    My question is why? I do not work at remote side. I do not know what happen in remote side. I am sure local I did not do anything.

    Anyone has any idea?


    Thanks in advance!


    Stacy

  2. #2
    Join Date
    Sep 2002
    Posts
    42
    It's all networking funda..Not at all related with oracle.The files /etc/nameserver has been changed after you created the DB_LINK .

    If you use absoulte IP address which ofcourse you did there is no need for nameserver (name resolution)

    So we better use absolute IP rather than alias in our tnsnames.ora file

    I hope this clears the doubt

    In GOD I find everything

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width