how to change shmmax parameter
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: how to change shmmax parameter

  1. #1
    Join Date
    Dec 2000
    Posts
    255
    I am using oracle 9i on RH linux 7.2. I need to increase the shmmax permanently as it is said in one oof installation documentation. How should I do it. I am getting error "Shared oracle memory realm does not exist'. Is it because of less shared memory.

    It is also affecting my auto startup of DB

    Amol

  2. #2
    Join Date
    Nov 2000
    Location
    Israel
    Posts
    268
    Steps required to install Oracle on Linux:
    1) log in as root.
    2) Create a Software Owner and Group. user=oracle, group=dba.
    3) Create the software mount point (ex. /home/oracle).
    4) grant permissions to oracle user on the mount point.
    5) set up environment variables:
    ORACLE_BASE /home/oracle/
    ORACLE_HOME /home/oracle/product/8.1.7
    LD_LIBRARY_PATH /home/oracle/product/8.1.7/lib:/usr/lib
    ORACLE_TERM vt100
    PATH /home/oracle/product/8.1.7/bin (followed by whatever else is usually in your PATH)
    ORACLE_SID your instance name

    6) Set the umask for user oracle to 022.
    7) To modify kernel parameters using the /proc file system:
    Change to the /proc/sys/kernel directory.
    Review the current semaphore parameter values in the sem file using the cat or more utility. For example,
    # cat sem
    The output will list, in order, the values for the SEMMSL, SEMMNS, SEMOPM and SEMMNI parameters. The following example shows how the output will appear.

    250 32000 32 128

    In the preceding example, the shared_memory_parameter is either the SHMMAX or SHMMNI parameter. The parameter name must be entered in lowercase letters.

    Modify the shared memory parameter using the echo utility. For example, to modify the SHMMAX parameter, enter the following:

    # echo 2147483648 > shmmax


    log in as oracle user set the SID and startup the instance nomount.

  3. #3
    Join Date
    Dec 2000
    Posts
    255
    I tried that while installation but it was temporary change. when
    I rebbted the machine it again became the same old one

    Amol

  4. #4
    Join Date
    Dec 2001
    Posts
    203
    Hello Amol

    Go to /etc system file and change the value for SHMMAX there. This is a permanent change.

    Thanks
    Sumit
    sumit

  5. #5
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    look man sysctl

    the create sysctl.conf in /etc then create a script in init.d and add SXX and KXX script in your run level directory (normally is 3)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width