Very unusual problem
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: Very unusual problem

  1. #1
    Join Date
    Apr 2002
    Posts
    291
    Hi Gurus
    I'm getting a very strange problem. All of aa sudden i'm encoutered with this error both on the server and on the client sides also.and i'm still getting this. The strange part is we are having two machines with same OS and DB and the same setup, very thing quite similar. But we facing this error on only one machine, other is working fine, both are production machines.

    Please look into the errors.

    Our OS is linux 7.1 , Oracle 9.0.1.
    All of a sudden i'm getting

    "
    ORA-12500: TNS:listener failed to start a dedicated server process" and kicked out of oracle. " This is on client side, either sqlplus session or TOAD.

    and also, On server side, i'm getting this error.

    [oracle@cmsprod1 41dbexport]$ sqlplus

    SQL*Plus: Release 9.0.1.0.0 - Production on Mon Sep 2 00:47:32 2002

    (c) Copyright 2001 Oracle Corporation. All rights reserved.

    Enter user-name: devlcms
    Enter password:
    ERROR:
    ORA-12547: TNS:lost contact
    At this point of time, i'm also getting,
    "[oracle@cmsprod1 41dbexport]$ exp help=y
    Segmentation fault (core dumped)"

    Any one can help me please. Our LD_LIBRARY_PATH is not set on both the machines. But one is working fine and the other is not.

    Waiting for your reply,

    Thanks in advance


    Pnrdba












    PNRDBA

  2. #2
    Join Date
    Jun 2000
    Posts
    179

    Talking

    Turn on Tracing for Listener and try to identify through generated files.

    Are you using dedicated or shared server modes.

    Maybe you are encountering problems from the client machine ( need re-istallation Oracle Soft. for instance ) or from the network line but its too early to decide , just turn on tracing and see.

    Reboot the server and try to connect also from the faulty machine alone and see.

    Good Luck
    Hisham Nagia
    IT Manager For Development
    Oracle Consultant - OCP

  3. #3
    Join Date
    Apr 2002
    Posts
    291
    Hi,
    Ours is a dedicated server. We already did a re-installation of oracle S/W. But again getting the same problem. The other machine is working fine.

    Waiting for your reply

    Thanks in advance

    Pnrdba
    PNRDBA

  4. #4
    Join Date
    Aug 2002
    Location
    Bangalore, India
    Posts
    405

    Post

    Originally posted by pnrdba
    Hi,
    Ours is a dedicated server. We already did a re-installation of oracle S/W. But again getting the same problem. The other machine is working fine.

    Waiting for your reply

    Thanks in advance

    Pnrdba
    Pls do post the following details. sort_area_size, sort_area_retained_size, no. of sessions connected to Oracle at the time of error, your sga statistics, paging space, no. of processes connected to server at the tome of error. Pls check for the msgs in "errpt" (aix version, don't know about Linux) and post the details. This looks like more of OS level problem.

    -nagarjuna

  5. #5
    Join Date
    Sep 2001
    Location
    NJ, USA
    Posts
    1,287
    An don't forget linux kernel parameters.
    It seems like problem with # of semaphores or # of OS procesess.

  6. #6
    Join Date
    Aug 2002
    Location
    Bangalore, India
    Posts
    405

    Smile

    Originally posted by Shestakov
    An don't forget linux kernel parameters.
    It seems like problem with # of semaphores or # of OS procesess.
    Exactly....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width