DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2002
    I am running Oracle 8.1.6 on Windows NT 4.0, Everyday I lose connection to database at least 2 times a day.
    I checked the AWSALRT.log

    I see:
    Thread 1 advanced to log sequence 2896
    Current log# 2 seq# 2896 mem# 0: D:\AWS_DB\REDO02.LOG
    Thu Aug 29 09:18:01 2002
    Errors in file D:\Oracle\Ora81\RDBMS\trace\awsCKPT.TRC:
    ORA-00206: error in writing (block 3, # blocks 1) of controlfile
    ORA-00202: controlfile: 'D:\AWS_DB\CONTROL01.CTL'
    ORA-27072: skgfdisp: I/O error
    OSD-04008: WriteFile() failure, unable to write to file
    O/S-Error: (OS 33) The process cannot access the file because
    another process has locked a portion of the file.

    Thu Aug 29 09:18:01 2002
    CKPT: terminating instance due to error 221
    Instance terminated by CKPT, pid = 329

    I tried using NTHandle program which finds out what are all the processes accessing the Oracle.exe, I find 3 other processes

    These are the windows processes at winnt\system32.

    I am running out of options please help.

  2. #2
    Join Date
    Jan 2001
    I don't suppose you have an NT administrator there do you?
    To me it appears that for some reason NT can not write to the control file, this is a bad thing. Is it shutting down the instance, it appears to be.

    My spidey sense tells me that you should make sure you have valid copies of your control files (and all critical files)ASAP, something about these errors scares me. I hope I am mistaken.

    Did you tkprof the trace file listed?

    I remember when this place was cool.

  3. #3
    Join Date
    Dec 2000
    Ljubljana, Slovenia
    Do you have any third party backup software backing up the database when that happens?

    According to Metalink, such errors (exactly the same error stack) are caused by: "....Typically this error is caused by 3rd party backup software placing a lock on an Oracle file and then when Oracle tries to write to it, the OS 33 is generated and the database will crash."

    Check metalink note 130871.1 and doc.id 352819.999 in Metalink's Technical Forum.
    Jurij Modic
    ASCII a stupid question, get a stupid ANSI
    24 hours in a day .... 24 beer in a case .... coincidence?

  4. #4
    Join Date
    Aug 2002
    virus checker? I've been burned by that one before, virus checker locks control file as it scan 'em, oracle tries to write to control file and you will be terminated ;-)

    I'm stmontgo and I approve of this message

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.