A complex problem !!
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: A complex problem !!

  1. #1
    Join Date
    Jul 2000
    Posts
    521
    Let me try to explain : (And we already have a couple of "work in progress" TARs open with Oracle @ this)

    Two servers (S1 and S2), one database running on each of them (D1 and D2 respectively) and a Pro*C program (P1) is what the setup and origin of problem is.

    The program is configured to be able run from S1 as well as S2. The program basically needs to make a connection to database D1 on server S1. Now, if the job is fired from server S1, the job can identify that and decides to make a BEQ connection. If its fired from server S2, it connects to database D1 using SQL*Net (TCP/IP) connection.

    After connecting, the job does DMLs on tables in database D1 as well as on tables in database D2. The tables in database D2 are available to the userid (that is used by the job to establish connection to database D1) by synonyms defined over a database link.

    The problem is as follows :
    When the job makes a BEQ connection, it sometimes fails due to "ORA-12571 TNS packet writer failure" error. When it makes a TCP/IP connection(irrespective of which server it is running on), it never fails.

    We have traced the sessions and found nothing except a "err=1013". How do we determine whether this caused the other error (12571) to occur or the 12571 caused this 1013 ro occur ?

    Any ideas @ where should we be looking ?

    The databases are 806 and OS is HP-UX 11i

    Thanks !!
    svk

  2. #2
    Join Date
    Aug 2000
    Location
    Chicago IL
    Posts
    586
    maybe u are getting dead connections...have u tried SQLNET_EXPIRE_TIME in ur server sqlnet.ora?
    "High Salaries = Happiness = Project Success."

  3. #3
    Join Date
    Jul 2000
    Posts
    521
    We do not have that parameter set. And there is some history behind that...Once it was suggested by Oracle to put that parameter. On one other occassion, they suggested to take it out !!

    Ultimately, we do not have that set.
    svk

  4. #4
    Join Date
    Aug 2000
    Location
    Chicago IL
    Posts
    586
    Why dont you test that Parm and see if it fixes your problem? You might be having TCP delays...
    "High Salaries = Happiness = Project Success."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width