Can't add datafile to a table space
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 9 of 9

Thread: Can't add datafile to a table space

  1. #1
    Join Date
    Aug 2002
    Posts
    8

    Exclamation

    I was getting an error when adding datafile to a tablespace. The message indicates that it reaches the max datafiles allowed for this tablespace. What can I do?

    Urgent!

    Thanks,

    YM

  2. #2
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,095
    What's the error message & Number?

    It might be as easy as checking the init.ora parameter db_files and increasing it.
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  3. #3
    Join Date
    Apr 2002
    Posts
    55
    check the db_files parameter .

    If it is less then increase the number.

    shutdown the database and restart the database.

    u are done
    VenDe ChukPeen Zuri

    Someone who quotes himself as a DBA and posts simple question in forums is a big idiot to me . I donot care what others think

  4. #4
    Join Date
    Feb 2000
    Location
    Singapore
    Posts
    1,758
    If it is not due to db_files limitation in init.ora then it may be bacause of the maxdatafiles limit in control file.

    HTH
    Sanjay

  5. #5
    Join Date
    Jul 2002
    Location
    Lincolnshire, IL
    Posts
    203
    Dear Sanjay, Give a solution brother for this...how can you change that in control file??
    See at the time of database creation you might have given low MAXDATAFILES value.
    Change your init.ora parameter(db_files). It will work...
    Sandy
    "Greatest Rewards come only with Greatest Commitments!"

  6. #6
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,448
    Originally posted by sandycrab
    Dear Sanjay, Give a solution brother for this...how can you change that in control file??
    See at the time of database creation you might have given low MAXDATAFILES value.
    Change your init.ora parameter(db_files). It will work...
    Sandy
    it will work in 8i but in 7/8 you have to recreate control files

  7. #7
    Join Date
    Feb 2000
    Location
    Singapore
    Posts
    1,758
    ALTER DATABASE BACKUP CONTROLFILE TO TRACE;

    Edit the script generated in udump directory.

    Recreate controlfile.

    HTH

    Sanjay

  8. #8
    Join Date
    Jun 2001
    Location
    Helsinki. Finland
    Posts
    3,938
    Often upon DB creation, MAXDATAFILES is left to its default value which is OS-specific, for UNIX it is often 30, for NT it is 254 for Oracle 8 and 8i, for VMS there is no limit in 8i as far as I remember. Often left with the default value of 30 for UNIX, the DBA comes to a point when he has to recreate the CF. I guess this is your case, right?
    Oracle Certified Master
    Oracle Certified Professional 6i,8i,9i,10g,11g
    email: ocp_9i@yahoo.com

  9. #9
    Join Date
    Aug 2002
    Posts
    8

    Thank you all so much. I didn't realize that I got the support back so fast. I was wondering why it was taking so long. This is my first time. I think my e-mail notification function was not set up right in my profile.

    Again, thank you very much.

    ym

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width