ORA-12500 TNS: listener...
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: ORA-12500 TNS: listener...

  1. #1
    Join Date
    Jul 2002
    Location
    Lincolnshire, IL
    Posts
    203
    Hi friends,
    Looking for one solution...hope you can help me out...
    I have a Oracle 8i database in my Win-2000 machine. Now I'm trying to connect using internal account. Not a problem, it is connecting fine. But when I try to connect as sys or system on same machine(server) or from some client it throws following error...
    ORA-12500 TNS: listener failed to start a dedicated shared server proces.
    I have checked my listener.ora and tnsnames.ora also. Everything seems to look fine there.
    Any idea about this...Tgis is really urgent friends
    Thanks in advance
    Sandy
    "Greatest Rewards come only with Greatest Commitments!"

  2. #2
    Join Date
    Sep 2000
    Posts
    305
    what is the setting of MTS in your init.ora?

  3. #3
    Join Date
    Jul 2002
    Location
    Lincolnshire, IL
    Posts
    203
    mts_dispatchers = "(PROTOCOL=TCP)(PRE=oracle.aurora.server.SGiopServer)"
    This is the one are you looking for??
    sandy
    "Greatest Rewards come only with Greatest Commitments!"

  4. #4
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,448
    nothing to do with MTS, most probably is your server resources are too low

  5. #5
    Join Date
    Jul 2002
    Location
    Lincolnshire, IL
    Posts
    203
    Thanks Pando,
    Please tell me what can be the problem. System resources like what?? Can you give me some precise solution? My manager is sitting on top of my head yaar. This is a Windows machine with 256 RAM.
    One more thing I'm able to start the database. Internal can do all the operations finely. But other users on same machine or clients are not able to connect. Any solution sir??
    Sandy
    "Greatest Rewards come only with Greatest Commitments!"

  6. #6
    Join Date
    Jan 2002
    Location
    Netherlands
    Posts
    1,591
    You have enough memory.
    Check:SID_LIST section of the LISTENER.ORA file
    or
    SERVICE_NAME in the CONNECT DATA section of the TNSNAMES.ORA file is incorrect.
    Check'em both!!
    It could also have to do with the access/if you have adequate privs to access the db.
    Tarry Singh
    I'm a JOLE(JavaOracleLinuxEnthusiast)
    TarryBlogging
    --- Everything was meant to be---

  7. #7
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,448
    resources like RAM (swapping?)
    100% CPU usage?

    Listener cannot spawn more processes when there are no resources for him to do it.
    256mb RAM sounds silly for a database server anyways... even my PC has more than that

    Tarry what you said has nothing to do with this error really, processes is related to server resources not sid list, connect data etc


  8. #8
    Join Date
    Sep 2000
    Posts
    305
    SANDYCRAB

    ARE YOU GETTING THIS PROBELM FIRST TIME YOU ALREADY FACED THIS PROBLEM BEFORE?
    I MEAN ARE YOU TRYING TO CONNECT WITH SYS AND SYSTEM FIRST TIME OR YOU HAD TRIED BEFORE.

    SHAILENDRA

  9. #9
    Join Date
    Sep 2000
    Posts
    305
    PANDO

    IS THERE ANY WAY TO FIND OUT THAT THE AVAILIABLE MEMORY IS NOT SUFFICIENT BECAUSE IF I ORDERED FOR EXTRA RAM THEN I SHOULD KNOW HOW MUCH MORE RAM IS REQUIRED?

    SHAILENDRA

  10. #10
    Join Date
    Jan 2002
    Location
    Netherlands
    Posts
    1,591
    pando i know that, since it being an error in the networking layer, i'd double check the mentioned parameters as well.
    Tarry Singh
    I'm a JOLE(JavaOracleLinuxEnthusiast)
    TarryBlogging
    --- Everything was meant to be---

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width