MEMORY I/O CONTENTION ON ORACLE 9I - Page 3
DBAsupport.com Forums - Powered by vBulletin
Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: MEMORY I/O CONTENTION ON ORACLE 9I

  1. #21
    Join Date
    Oct 2001
    Posts
    126
    If you didn't get any error message, the following info might not apply to your case.

    *******************************************
    Patch::2391227

    ORA-04030: OUT OF PROCESS MEMORY, SUBHEAP, CONCURRENT INSERT
    *******************************************

    Susan


  2. #22
    Join Date
    Jan 2002
    Posts
    474
    this is the only warning I got when I startup my database other than that I don't have any errors:

    Mon Jul 29 16:10:15 2002
    Starting ORACLE instance (normal)
    Mon Jul 29 16:10:15 2002
    WARNING: EINVAL creating segment of size 0x0000000007400000
    fix shm parameters in /etc/system or equivalent
    LICENSE_MAX_SESSION = 0
    LICENSE_SESSIONS_WARNING = 0
    SCN scheme 2
    Using log_archive_dest parameter default value
    LICENSE_MAX_USERS = 0
    SYS auditing is disabled
    Starting up ORACLE RDBMS Version: 9.2.0.1.0.
    System parameters with non-default values:
    processes = 150
    timed_statistics = TRUE

  3. #23
    Join Date
    Oct 2001
    Posts
    126
    fix shm parameters in /etc/system or equivalent
    *******************************************
    This is the answer to your case. You need to modify your /etc/system file. This file contains information about the OS kernal. On the installation menu of 9i, you will find the related info on p2-20.

    Susan

  4. #24
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    echo 671088640 > /proc/sys/kernel/shmmax

    bounce the database

  5. #25
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    Hmm, imagine that, a kernal parameter problem.
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  6. #26
    Join Date
    Jan 2002
    Posts
    474
    Thanks Pando, Jeff and srlhome00 so much and I have the feeling that something to do with the Kernal but I am not sure b/c I am new with Linux

    I run what Pando advise me to run : Log in as root and I run:

    echo 671088640 > /proc/sys/kernel/shmmax

    and I did bounce the database


    CPU states: 0.0% user, 0.0% system, 0.0% nice, 100.0% idle
    Mem: 643708K av, 57416K used, 586292K free, 0K shrd, 4764K buff
    Swap: 1518100K av, 0K used, 1518100K free 22920K cached



    and this is after I just run analyze statistic on one schema which had about 150 tables:


    CPU states: 0.1% user, 0.1% system, 0.0% nice, 99.6% idle
    Mem: 643708K av, 634884K used, 8824K free, 0K shrd, 25296K buff
    Swap: 1518100K av, 0K used, 1518100K free 563068K cached


    The question is I could understand the memory will peak up b/c of the process I ran but how come it doesn't go down when this process finish ???

    please don't be upset if I keep coming back with this issue but it does bother me.

    thanks so much for all of help.



  7. #27
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    I have already told you Linux tries to cache everything in memory even your process finishes linux allocates free memory to other processes
    No matter what you do you will see 640MB being used, what's the point having 640MB if you only use 100MB? Linux tries to make good use of all of them

  8. #28
    Join Date
    Jan 2002
    Posts
    474
    Jeff and Pando,

    I am sorry I hate to comeback this thread again, but I have a question. I still had the warning on the alert log file. please help me with this even I already update the kernel per your advise

    below is the warning on my log:





    Starting ORACLE instance (normal)
    Thu Aug 1 09:44:14 2002
    WARNING: EINVAL creating segment of size 0x0000000007400000
    fix shm parameters in /etc/system or equivalent
    Thu Aug 1 09:44:32 2002
    Starting ORACLE instance (normal)
    Thu Aug 1 09:44:32 2002
    WARNING: EINVAL creating segment of size 0x0000000007400000
    fix shm parameters in /etc/system or equivalent
    LICENSE_MAX_SESSION = 0
    LICENSE_SESSIONS_WARNING = 0
    SCN scheme 2
    Using log_archive_dest parameter default value
    LICENSE_MAX_USERS = 0
    SYS auditing is disabled
    Starting up ORACLE RDBMS Version: 9.2.0.1.0.
    System parameters with non-default values:


    Could you please let me know what I need to do ???

    Thanks


  9. #29
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    echo value /proc/sys/kernel/shmmax stops working after the server is rebooted

    you have to create a script in /etc/init.d to make this change everytime your server is rebooted

  10. #30
    Join Date
    Jan 2002
    Posts
    474
    Pando,

    you could add the change in here

    /etc/rc.local

    and it will change

    Any way, thanks so much for your help


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width