Auto Archive log not getting enabled
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Auto Archive log not getting enabled

Hybrid View

  1. #1
    Join Date
    Dec 2000
    Posts
    255
    I have made the folowing settings in my initkdb.ora file. 

    log_archive_start=true
    log_archive_dest='/usr/local/localamol/oradata/archivelog'
    log_archive_format = _%s.arc

    I have also started the database in the archive log mode , still the database is showing me the auto archival is disabled. What is the parameter I have to set to start the automatic archival. The ARCHIVE LOG LIST command gives following results.

    Database log mode Archive Mode
    Automatic archival Disabled
    Archive destination /opt/oracle/product/9.0.1/dbs/arch
    Oldest online log sequence 4
    Next log sequence to archive 5
    Current log sequence 6

    Amol

  2. #2
    Join Date
    Nov 2001
    Location
    Delhi
    Posts
    31
    Originally posted by amolik
    I have made the folowing settings in my initkdb.ora file. 

    log_archive_start=true
    log_archive_dest='/usr/local/localamol/oradata/archivelog'
    log_archive_format = _%s.arc

    I have also started the database in the archive log mode , still the database is showing me the auto archival is disabled. What is the parameter I have to set to start the automatic archival. The ARCHIVE LOG LIST command gives following results.

    Database log mode Archive Mode
    Automatic archival Disabled
    Archive destination /opt/oracle/product/9.0.1/dbs/arch
    Oldest online log sequence 4
    Next log sequence to archive 5
    Current log sequence 6

    Amol
    Dear Mr Amol!
    What ever you have done that is OK .But you have to start manaualy first time to your database in archive mod.For this just you start your darabase and after that connect as server manager and
    apply the command
    archive log start;
    Now I think you problem will be solved
    Thanks
    Imtiaz
    Imti
    Junior DBA

  3. #3
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    1. Shutdown the instance with shutdown immediate
    2. Startup mount
    3. Alter database archivelog;
    4. Alter database open;

    Cheers

    Angel

  4. #4
    Join Date
    Dec 2000
    Posts
    255
    Hi Imti , Angel

    I did as per you said. It starts for that instance when I say Archive log start' but it doesn't enable it if I have to shutdown and restart database. If this database is started it still shows AUTO ARCHIVAL as disabled

    Amol

  5. #5
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    Did you do alter database archivelog after mounting the database?

  6. #6
    Join Date
    Dec 2000
    Posts
    255
    Hi

    I have done with following sequence.
    1) Changed in initkendb.ora file
    2) shutdown current database
    3) startup mount
    4) alter databae archivelog;
    5) alter database open;
    6) archive log start

    Then it showed me auto archival as enabled but when I restarted the database the lo mode was 'archive log' only but auto archival was 'Disabled'. I am using initkendb.ora in /opt/oracle/admin/kendb/pfile/
    and which has symbolink link to $ORACLE_HOME/dbs/init.ora (same parameters). What can be the problem. Am I using correct parameter file. How do I know that oracle using which parameter file.

    (Note: I queried V$PARAMETER file but it showed me log_archive_start as false. That means Oracle is using wrong file ... but which ?)

    Amol

  7. #7
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    It is nt or unix?

    If it is NT/2000 you could search in the registry wich is the default Oracle_yourinstance_PFILE.

    Cheers

    Angel

  8. #8
    Join Date
    Dec 2000
    Posts
    255
    IT's RH Linux 7.2 with oracle 9i

    Amol

  9. #9
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    Probably it is getting the default init in dbs. Then delete all lines in this file (make a backup of the file) and add the next:

    ifile=the path where it is your init modified, then restart the database.

    Cheers

    Angel

  10. #10
    Join Date
    Dec 2000
    Posts
    255
    There is a file spfilekendb.ora in $ORACLE_HOME/dbs/

    If I remove this file and create another file with ifile pointed to proper parameter file and start the database then it gives me the error 'end of communication channel' .
    Even if I modify the spfilekendb.ora then also the same error occurrs.
    (ORA-03113). I googled on this error not nothing comes up. It is a generalised error.
    Can anyone tell me why this is happening. In which file the parameter is stored which tells oracle to access file name only spfilekendb.ora. Even if I comment any of the parameters the database does not starts.
    Evenif I set ifile in spfilekendb.ora it does not work.

    Amol

    (Note: the spfilekendb.ora contains some binary data as well and the parameter starts with *. Now why is that)

    Expecting help...otherwise may not be able to modify init.ora any time.

    Amol



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width