sys can not logon as sysdba
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: sys can not logon as sysdba

Hybrid View

  1. #1
    Join Date
    Mar 2002
    Posts
    25
    I applied two patches to my base 8.1.6 (8i) last night to bring it to 8.1.6.3.8 Now, when entering the database I can't connect sys or internal as sysdba - only as normal. The error tells me that it is an invalid username or password but I can use the same username and password to connect as normal. What is the best way to remedy this? I am on a windows 2000 platform.

  2. #2
    Join Date
    Jan 2002
    Location
    Netherlands
    Posts
    1,587
    Originally posted by ratfink
    I applied two patches to my base 8.1.6 (8i) last night to bring it to 8.1.6.3.8 Now, when entering the database I can't connect sys or internal as sysdba - only as normal. The error tells me that it is an invalid username or password but I can use the same username and password to connect as normal. What is the best way to remedy this? I am on a windows 2000 platform.
    Strange , what does contents of v$pwfile_users say?
    Tarry Singh
    I'm a JOLE(JavaOracleLinuxEnthusiast)
    TarryBlogging
    --- Everything was meant to be---

  3. #3
    Join Date
    Jun 2000
    Location
    Madrid, Spain
    Posts
    7,447
    try recreate the password file

  4. #4
    Join Date
    Mar 2002
    Posts
    25
    I tried recreating the password file, rebooting but it didn't help. We have a DBA consultant that is comming in tonight. I will finish this thread tomorrow with the results. Thank you for your input.

  5. #5
    Join Date
    Jan 2002
    Location
    Netherlands
    Posts
    1,587
    While you're at it, did you try connecting as
    connect internal/pwd@string as sysdba
    That shud have worked.
    Interesting note:
    I ended up similarly with a rather unexplainable situation. I had a pwd veify fxn ran on my test db, after a certain period of time ,which was today i was prompted in my sql*plus to change pwd of user sys, so i did.
    Now within the sql*plus i did again
    connect sys/newpwd@string as sysdba
    no luck!
    then i did
    internal/pwd@string as sysdba
    ok!
    and then i said hey let's try
    connect sys/oldpwd@string as sysdba.
    OK!!!?
    I for now don't have a clue but i'll prod on..............
    Tarry Singh
    I'm a JOLE(JavaOracleLinuxEnthusiast)
    TarryBlogging
    --- Everything was meant to be---

  6. #6
    Join Date
    Mar 2002
    Posts
    25

    Angry

    So far nothing has worked. Tried the v$pwfile_users and it returned no rows! Tried your connect internal trick - nada! Tried changing the internal password using oradim - nothing. Recreated the password file multiple times - rebooted - nothing! We are tearing our hair out now.... sys will logon fine as sysoper or normal but not sysdba. Internal can't logon as all. System still will work with normal. Any more ideas??? Nothing that I have gotten from metalink has worked.

  7. #7
    Join Date
    Feb 2000
    Location
    Singapore
    Posts
    1,758
    Make sure that the parameter REMOTE_LOGIN_PASSWORDFILE is set to EXCLUSIVE?

    Sanjay

  8. #8
    Join Date
    Mar 2002
    Posts
    25

    Wink

    We finally figured it out. Thank you everyone for your help. As you read this you will see how everyone's contribution fit in. We had the correct stuff - just the wrong order of things and I hadn't shut down the db and services. This is what we did and it worked - I have two sids that I had to do this with.

    To change the password for “internal”
    Stop the database and all services first.
    at the command line:
    Make sure you are in the correct SID by first typing
    SET ORACLE_SID=
    Then SET ORACLE_SID to make sure that it worked

    oradim –edit –sid –intpwd

    Also – while the services are still off – rename or remove the password file for the sid located in InstallDrive:/Oracle/Ora81/DATABASE.
    at the command line (make sure that Oracle/Ora81/BIN is in path):

    InstallDrive:/Oracle/Ora81/DATABASE /orapw file=PWD.ORA password= entries=5

    Now check the init.ora file located in Oracle/Ora81/Admin/Orcl/pfile and make sure that remote_login_passwordfile=exclusive. Do not comment out.
    Start up the database and all services.

    To change the password for “sys”
    In SQL*Plus :

    Alter user sys identified by
    Both the internal and sys password should be the same.

  9. #9
    Join Date
    May 2002
    Posts
    2,645
    How much did you pay for this? I could have told you this for free.

  10. #10
    Join Date
    Mar 2002
    Posts
    25

    Talking

    Now you tell me!!! Tee Hee! It's alright, he was a good friend of mine

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width