DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Utl_File error

  1. #1
    Join Date
    Jan 2002
    I have an utl_file that reads data from text file into an oracle database.
    the problem I am having right now is if I have three records in the text file I am reading from, my code works fine but if I have more than three records in the file, I get a PL/SQL error which says:
    ERROR: -6502-ORA-06502: PL/SQL: numeric or value error: character string buffer too small.
    I originally set the string buffer to 100. eg.
    strbuffer VARCHAR2(100); -- input file.
    I changed the size to strbuffer VARCHAR2(2000); -- input file
    I still get the same error.
    How can solve this problem.
    Thanks in advance.

  2. #2
    Join Date
    Feb 2001
    location IN VARCHAR2,
    filename IN VARCHAR2,
    open_mode IN VARCHAR2,
    max_linesize IN BINARY_INTEGER) <<<< Is this Oke
    RETURN file_type;

    Ben de Boer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width

We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.