db link problem(global_names)
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: db link problem(global_names)

  1. #1
    Join Date
    Oct 2001
    Posts
    13
    Hi,

    We are having a database where global_names=true and db_domain parameters are set.

    Because of these parameters the database is restricting the db link name to be same as the global_name (ie dbname+domainname)

    We want to disable the two parameters.

    I commented the parameters in the init.ora file
    and
    issued
    alter system set global_names=false;

    I even tried to change the global_name with

    alter database rename global_names to xxx;

    but still not able to create db link with any name.
    Any help will greatly help me.

    Regards,
    Sreelatha

  2. #2
    Join Date
    Nov 2000
    Location
    greenwich.ct.us
    Posts
    9,092
    global_names is most likely your problem. I would explicitly set global_names to false in the init.ora and bounce your database.

    You can check it's value by:
    Code:
    SQL> l
      1  select name, value, isdefault, issys_modifiable, ismodified, isadjusted
      2  from v$parameter
      3* where name like '%global%'
    Jeff Hunter
    marist89@yahoo.com
    http://marist89.blogspot.com/
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

  3. #3
    Join Date
    Apr 2002
    Location
    Phoenix, AZ
    Posts
    175
    1. Are you creating a private or public link
    2. Do you have DBA Privs to the user you are trying to do the operation with
    3. What is the error. I never came across a situation where you "Cannot Create a Link", it was always the fact that you can create a link but it was not working. What is the error message oracle gave

    Can you please post the exact SQL statement you used to create the link

  4. #4
    Join Date
    Oct 2000
    Location
    Germany
    Posts
    1,185
    You can use "Alter Session" to change the session parameters, but i believe you must bounce the database to change the global_names option at the database level.

    In either case, you can try to create the link after issuing the

    "alter session set global_names = false" command.

    Good luck.
    David Knight
    OCP DBA 8i, 9i, 10g

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width