Create database error
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: Create database error

Hybrid View

  1. #1
    Join Date
    May 2002
    Posts
    4

    Question

    Hi!
    I am continously getting error in creating the database

    At command prompt I am giving the following command :-

    oradim -NEW -SID dtest -INTPWD dtest -STARTMODE AUTO

    SQL> startup nomount pfile=3D"e:\Oracle\admin\dtest\pfile\init.ora";
    ORACLE instance started.

    Total System Global Area 56476940 bytes
    Fixed Size 70924 bytes
    Variable Size 39550976 bytes
    Database Buffers 16777216 bytes
    Redo Buffers 77824 bytes
    SQL>=20
    SQL>=20
    SQL>=20
    SQL> CREATE DATABASE dtest
    2 LOGFILE 'e:\Oracle\oradata\dtest\redo01.log' SIZE 1024K,
    3 'e:\Oracle\oradata\dtest\redo02.log' SIZE 1024K,
    4 'e:\Oracle\oradata\dtest\redo03.log' SIZE 1024K
    5 MAXLOGFILES 32
    6 MAXLOGMEMBERS 2
    7 MAXLOGHISTORY 1
    8 DATAFILE 'e:\Oracle\oradata\dtest\system01.dbf' SIZE 58M =
    REUSE AUTOEXTEND ON NEXT 640K
    9 MAXDATAFILES 254
    10 MAXINSTANCES 1
    11 CHARACTER SET WE8ISO8859P1
    12 NATIONAL CHARACTER SET WE8ISO8859P1;
    CREATE DATABASE dtest
    *
    ERROR at line 1:
    ORA-01501: CREATE DATABASE failed
    ORA-01991: invalid password file 'e:\Oracle\Ora81\DATABASE\PWDsbasm.ORA'



    I have created all the directories req for this...and also a password =
    file=20
    for this exits in the path e:\Oracle\Ora81\DATABASE\PWDdtest.ORA'

    I fail to understand why is it taking the password file of my existing =
    database i.e. SBASM. ????

    Can anyone help me in this regard.

    Thanks
    Yan.

  2. #2
    Join Date
    Dec 2001
    Location
    UK
    Posts
    1,684
    It decides which passwordfile to use based on your current value of ORACLE_SID. Since you're using NT/2000 you can try one of several things:

    1) Comment out the remote_login_passwordfile=EXCLUSIVE entry from you init.ora then try again.

    2) Make sure the ORACLE_SID string in HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\HOME(x) is set correctly. I assume it currently says your the SID for your existing instance.

    3) Do "set ORACLE_SID=TSH1" at the command prompt before starting your DB creation. This only works for you current shell.

    If you use the DBCA it will sort all this out for you. If you want to do it by hand then use the DBCA and save the scripts rather than picking the create-now option.

    Cheers

    [Edited by TimHall on 05-21-2002 at 09:04 AM]
    Tim...
    OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
    OCA PL/SQL Developer
    Oracle ACE Director
    My website: www.oracle-base.com
    My blog: www.oracle-base.com/blog

  3. #3
    Join Date
    Aug 2000
    Location
    Straham NH
    Posts
    73
    Did you set the SID at the command prompt?

  4. #4
    Join Date
    May 2002
    Posts
    4
    1. I tried to insert # sign between REMOTE_LOGIN_PASSWORDFILE, but I can't connect to the sqlplus:
    SQL> connect sys/sys as sysdba
    :ERROR
    ORA-01017: invalid username/password; logon denied
    BUT, when I remove the sign and write exclusive option that connect is succed;

    2. I tried manually change regedit parameter ORACLE_SID onto new database SID (the database still not exist, but I built the SID by ORADIM command). But anyway, when the Create database finished, I got same message (all data files are created !)

    3. I use no Win NT or 2000.
    I use Windows 98 OS.

    Thank you.

  5. #5
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    I think it is not possible to install Oracle EE in Windows 98, only personal edition is available for this OS.

    Cheers

    Angel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width