Intermitted TNS-12500 error on Windows NT
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 4 of 4

Thread: Intermitted TNS-12500 error on Windows NT

  1. #1
    Join Date
    Mar 2002
    Location
    Manchester, England
    Posts
    202
    Hi All,
    I'm after a little guidance and insight from the collective.

    We are seeing the following errors in the Listner.log when the connection numbers get fairly high (approx 700 connections). We are running 8.1.7 on NT SP6a (the box has 2GB), initially the SGA was configures to use about 1.2GB...we reduced this when we hit these errors to 950Mb (to give the OS more resource) and this had the effect of increasing the number of connection before the errors returned.

    Has anyone seen this before and how can it be avoided - apart from moving to Unix ;-)

    cheers
    chris


    example message
    03-MAY-2002 09:53:40 * (CONNECT_DATA=(SERVICE_NAME=cad2)(CID=(PROGRAM=C:\win32app\ingr\ICALL\bin\icall.exe)(HOST=STRE111418 Q)(USER=JamesKX))) * (ADDRESS=(PROTOCOL=tcp)(HOST=192.168.131.90)(PORT=1638)) * establish * cad2 * 12500
    TNS-12500: TNS:listener failed to start a dedicated server process
    TNS-12540: TNS:internal limit restriction exceeded
    TNS-12560: TNSrotocol adapter error
    TNS-00510: Internal limit restriction exceeded
    32-bit Windows Error: 8: Exec format error


  2. #2
    Join Date
    Mar 2002
    Location
    Manchester, England
    Posts
    202
    I've had a suggestion from someone that points the finger at the number of internal threads that oracle.exe can spawn.

    Apparently its 800 on NT....does this ring true with anyone??

    chris

  3. #3
    Join Date
    May 2002
    Posts
    37

    Smile

    hi,
    you can try several things
    1. reduce to minimum following init.ora parameters that affect
    size of memory for new session:
    - bitmap_merge_area_size
    - create_bitmap_area_size
    - hash_area_size
    - sort_area_size (biggest memory consumer)

    2. Disable OTRACE, which is enabled by default
    - stop oracle database
    - go to $ORACLE_HOME\otrace\admin and delete all files
    with a '.dat' extension.
    - restart database

    3. Increase the amount of swap space.

    4. Consider switching to Oracle Multi Threaded Server (MTS).

    Regards,

    dave777

  4. #4
    Join Date
    Mar 2002
    Location
    Manchester, England
    Posts
    202
    hi,
    Thanks for the reply.

    Its been suggested that it is also a symptom of an oracle.exe having a problem spawning additional threads. Apparently, Oracle on NT has a limit on the number of threads that can be spawned and this number is 800. One solution it to implement MTS but I'm not sure the application can deal with that...if this is the case and the thread limit is hard set then we are in trouble.

    If anyone has any ideas...keep em coming

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width