Error 41836 I/O error on tmp buffer
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Error 41836 I/O error on tmp buffer

  1. #1
    Join Date
    Apr 2002
    Posts
    2
    I've got an interesting problem.
    I have two users who get the following error when they try to run a long report.

    FRM-41836:Sisk I/O error on temporary record buffer file
    C:\WINNT\TEMP\2.TMP

    When I looked up this error on Metalink it suggested that there was not enough free disk space. When I examined their machines there appeared to be plenty of space.

    Another suggestion is that the TMP variable is set up incorrectly.

    Here are the assumptions I've made so far. Please tell me if they are wrong.

    Oracle Applications is trying to write a temp file called 2.TMP on the clients C: drive.

    The error is occuring because Oracle Applications can not find or open the 2.TMP file.

    My efforts so far have been in vain. Any suggestions?

    djharris86

  2. #2
    Join Date
    Apr 2002
    Posts
    2

    problem solved

    I've solved this problem. I've enclosed the solution for future reference.

    symptom: "FRM-41836 Disk I/O error on temp record buffer..." This happens when a large report is being run.

    reason: The temporary buffer is pointed to a location that the user does not have access to.

    solution: Change the path for the TEMP variable to a location the user can access such as C:\TEMP. You must have administration rights to make this change.

    Find the environment variables on the system control panel. Edit the system variable so that TEMP (I did TMP also) variable points to C:\TEMP or any temp file the user has access to.

    djharris86

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width