Good morning all,

I am trying to import a client dmp file into our database, however I kept getting the same error messages. The versions that the client and us using are the same, Oracle 7.3.2 on Unix HP, same database setting including schema. When I import the dmp file, I used,

imp system/pwd file=file.dmp fromuser=dail touser=dail grants=n ignore=y indexes=n

Then I got these errors,

Import: Release - Production on Thu Mar 28 08:30:08 2002

Copyright (c) Oracle Corporation 1979, 1994. All rights reserved.

Connected to: Oracle7 Server Release - Production Release
With the distributed, replication, parallel query and Spatial Data options
PL/SQL Release - Production

IMP-00037: Character set marker unknown
IMP-00021: operating system error - error code (dec 2, hex 0x2)
IMP-00000: Import terminated unsuccessfully

I checked the metal-link, and found couple documents discussing IMP-00037, said it was caused by corrupted export file. I asked the client to export the dmp file again, and ensure that the file was exported successfully, compressed with size around 2M, and ftp in binary mode. And again I got the same error message.

The IMP-00021: operating system error said the file was not found. Can anyone tell me why the OS cannot find the file while the Oracle was able to open the file (appear to be)? Is there possibly a corruption in the dmp file or I need to reset the NLS_CHARACTERSET during imp? If I do, how would I do that? Please advise how to import this file.