Statistics - Page 2
DBAsupport.com Forums - Powered by vBulletin
Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Statistics

  1. #11
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    Try to delete it manually:

    spool delete_statistics_tables

    select 'analyze table '||table_name||' delete statistics;'
    from dba_tables
    where owner='OWNER';

    spool off

    Run delete_statistics_tables

    spool delete_statistics_indexes

    select 'analyze index '||index_name||' delete statistics;'
    from dba_indexes
    where owner='OWNER';

    spool off

    Run delete statistics_indexes

    Hope this will help you

    Angel

  2. #12
    Join Date
    Jun 2001
    Location
    Helsinki. Finland
    Posts
    3,938
    Originally posted by PWC
    For information :
    Delete statistics don't work.
    I'll try in few days to set the parameter enable_type_dep_selective in the init.ora when I could restart the DB.

    Thx
    You don't have to set it. Just run in SQL*Plus "alter session set "_enable_type_dep_selectivity" = true;" and then collect the statistics.

    Oracle Certified Master
    Oracle Certified Professional 6i,8i,9i,10g,11g,12c
    email: ocp_9i@yahoo.com

  3. #13
    Join Date
    Sep 2001
    Posts
    34
    I've try to set "enable_type_dep_selectivity" = true but nothing is different ....

    Other idea ?

  4. #14
    Join Date
    Jun 2001
    Location
    Helsinki. Finland
    Posts
    3,938
    Originally posted by PWC
    I've try to set "enable_type_dep_selectivity" = true but nothing is different ....

    Other idea ?
    Flush the shared pool.

    Oracle Certified Master
    Oracle Certified Professional 6i,8i,9i,10g,11g,12c
    email: ocp_9i@yahoo.com

  5. #15
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    As Julian said in his earlier post. This parameter might help you or not, then unique workarround is to delete statistics and try again.

    Angel

  6. #16
    Join Date
    Jun 2001
    Location
    Helsinki. Finland
    Posts
    3,938
    Why don't you try using dbms_stats.gather_schema_stats instead? Check if the gives the same errors.

    Also, is optimizer_features_enable set properly?



    [Edited by julian on 03-21-2002 at 05:46 AM]
    Oracle Certified Master
    Oracle Certified Professional 6i,8i,9i,10g,11g,12c
    email: ocp_9i@yahoo.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width