ora-12520 error,help me.
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: ora-12520 error,help me.

  1. #1
    Join Date
    Jan 2002
    Posts
    26

    Angry

    I have set oracle9i as mts server,all MTS processes alse are running ,but when i use sqlplus to connect to oracle mts ,it is return error message ora-12520 .But i connect to it when force the dedicated mode in tnsnames.ora,it is ok .
    Any one can help me?

    [Edited by hepinge on 03-19-2002 at 07:18 AM]

  2. #2
    Join Date
    Feb 2000
    Posts
    175
    Hi,

    Use the 'lsnrctl services' command for the listener to see what has dispatchers/servers etc have been started and the status of each....

    Cheers
    Moff.

  3. #3
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    That was because your dispatchers have not been registered or started.

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  4. #4
    Join Date
    Jan 2002
    Posts
    26

    hi moff:

    Originally posted by moff
    Hi,

    Use the 'lsnrctl services' command for the listener to see what has dispatchers/servers etc have been started and the status of each....

    Cheers
    Moff.
    This is the part result of 'lsnrctl services'
    "D002"
    DISPATCHER
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=bbsdb)(PORT=33747))(PRESENTAT
    ION=oracle.aurora.server.SGiopServer)(SESSION=RAW))
    "D001" :
    DISPATCHER
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=bbsdb)(PORT=33746))(PRESENTAT
    ION=oracle.aurora.server.GiopServer)(SESSION=RAW))

    so how can i do?

  5. #5
    Join Date
    Jan 2002
    Posts
    26

    HI sambavan:

    Originally posted by sambavan
    That was because your dispatchers have not been registered or started.

    Sam

    Please see my reply above,please tell me how can i do??
    I think the dispatchers has been registered and started.Is that right?

  6. #6
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    Probably you have started your listener after you started the database, then your dispatchers haven't been initialized.

    You have to restart your database to initialize the dispatchers.

    Regards

    Angel

  7. #7
    Join Date
    Jan 2002
    Posts
    26

    hi aarroyob:

    Originally posted by aarroyob
    Probably you have started your listener after you started the database, then your dispatchers haven't been initialized.

    You have to restart your database to initialize the dispatchers.

    Regards

    Angel
    I first start listener and start oracle instance . Can you tell me is there something special on init.ora ¡¢listener.ora and client's tnsnames.ora in MTS mode?

  8. #8
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    What do you have in the init.ora, tnsnames.ora and listener.ora?


  9. #9
    Join Date
    Jan 2002
    Posts
    26

    hi aarroyob:

    parameters about mts in init.ora :

    dispatchers="(PROTOCOL=TCP)(SER=MODOSE)"
    dispatchers="(PROTOCOL=TCP)(PRE=oracle.aurora.server.GiopServer)"
    dispatchers="(PROTOCOL=TCP)(PRE=oracle.aurora.server.SGiopServer)"

    parameters in listener.ora :

    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC))
    )
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST =bbsdb)(PORT = 1521))
    )
    )
    )

    parameters in tnsnames.ora :

    CLUBDB =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = bbsdb)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = clubdb)
    (server=shared)
    )
    )







  10. #10
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    In my init.ora I have this:

    large_pool_size = 50M
    mts_servers = 10
    mts_max_servers=20
    mts_dispatchers="(ADDRESS=(PROTOCOL=tcp)(HOST=host_name)(PORT=1522))(dispatchers=1)"
    mts_dispatchers="(ADDRESS=(PROTOCOL=tcp)(HOST=host_name)(PORT=1523))(dispatchers=1)"
    mts_dispatchers="(ADDRESS=(PROTOCOL=tcp)(HOST=host_name)(PORT=1524))(dispatchers=1)"
    mts_dispatchers="(ADDRESS=(PROTOCOL=tcp)(HOST=host_name)(PORT=1525))(dispatchers=1)"
    mts_dispatchers="(ADDRESS=(PROTOCOL=tcp)(HOST=host_name)(PORT=1526))(dispatchers=1)"
    mts_max_dispatchers=20
    local_listener="(ADDRESS_LIST=(ADDRESS=(PROTOCOL=tcp)(HOST=host_name)(PORT=1521)))"
    mts_service=instance_name

    The other file i think are correct if your host_name=bbsdb. Is it?

    Cheers

    Angel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width