COntrol file failure - Page 2
DBAsupport.com Forums - Powered by vBulletin
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: COntrol file failure

  1. #11
    Join Date
    Mar 2002
    Posts
    60
    try shutdown abort;
    and then
    do startup nomount pfile='....../...'

    looks like ur instance was never mounted...

    Or I think since none of the control files are there instance cannot be mounted...

    check metalink if u have access to it..


  2. #12
    Join Date
    Sep 2001
    Location
    Jurong East/Singapore
    Posts
    70

    Thumbs up

    Hi b4 trying to create control file, stop and start the oracle service which u r trying to recreate the control file..

    it will may work out...
    let me know the result..

    regards!
    peri

  3. #13
    Join Date
    Oct 2000
    Posts
    467
    Check out the foll:-

    1. You cannot create controlfiles at mount stage. Your DB has to be in nomount stage.

    2. Before you attempt anything, backup all your files just in case something goes wrong. This is very important.

    Now for the recovery part -

    1. If multiple copies of controlfiles, you can simply copy your 2nd controlfile to your 1st controlfile directory and rename it. (do this while your db is shutdown.)

    2. IF you have an old copy of your controlfile then

    startup mount pfile ....
    alter database recover using backup controlfile.

    3. Another option will be to recreate it.

    startup nomount pfile...
    run your create controlfile sql here.


    Check out your alert logs .
    Vinit

  4. #14
    Join Date
    Mar 2002
    Posts
    4

    Thumbs up

    This may be related to bug 855721 which is a problem in the way that NT handles semaphores during the mount process. This evidently doesn't occur all the time, but can be reproduced as follows:

    1. Mount database failed (due to controlfile corrupted).
    2. Restore controlfile.
    3. Mount database again without shutdown -> Problem occured!
    When tried to mount the database, got ORA-1102(cannot
    mount database in EXCLUSIVE mode) and found following error in alert.log.
    Once this error occured, they can not mount the database even though they
    shutdowned the database.
    .
    ORA-09341: scumnt: unable to mount database
    OSD-04400: unable to acquire internal semaphore for process
    O/S-Error: (OS 183) Cannot create a file when that file already exists.

    This error occured only when they tried to mount database twice. And
    first try failed with error. For example..
    .
    1. Mount database failed (due to controlfile corrupted).
    2. Restore controlfile.
    3. Mount database again without shutdown -> Problem occured!
    .
    oracle80.exe create a semaphore scumntsem_ at mount. But this
    semaphore is not released properly when mount failed. I guess the handle
    of semaphore is lost at above situation and oracle80.exe can not release
    it correctly. To mount the database, the service of oracle database have
    to be restarted.
    This problem don't occur on solaris, so this is port specific problem.
    And I confirmed this problem occurs on all release of Oracle8 for
    WindowsNT.

    Solution :To restart service.

    1. Start Service.
    2. Startup nomount.
    2. Rename controlfile to another name.
    3. Mount database(alter database mount) -> ORA-205 occurs.
    4. Rename controlfile to original name.
    5. Mount database(alter database mount) -> ORA-1102 occurs(reproduced!).



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width