Bam buffer - ORA-04031 Forums - Powered by vBulletin
Results 1 to 2 of 2

Thread: Bam buffer - ORA-04031

  1. #1
    Join Date
    Jul 2000

    I had the following error on a production database yesterday :-

    ORA-04031: unable to allocate 4096 bytes of shared memory ("shared pool","BEGIN

    (Oracle - Solaris 8)

    I upped the size of the shared pool on the database and increased its reserved size, this seems to have solved the problem (although it could have been the database bounce that sorted it)

    Today, I had exactly the same error on a different database, so I'm wondering whether there is a problem with the box (both databases are on the same box) I also noticed that the shared_pool_reserved_size parameter is supposedly obsolete on 8.1.7 anyway...

    Prior to this, I'd never seen this error, and had only heard of it on development boxes where large pl/sql compilations are occurring.

    Any ideas?

    Thanks in advance,


  2. #2
    Join Date
    Nov 2000
    This error comes into play when you have shared pool fragmentation. However, in some 8.1.7 versions ( I know, not sure about there is a problem with the shared pool cleaning up. This bug is fixed in
    Jeff Hunter
    Get Firefox!
    "I pledge to stop eating sharks fin soup and will not do so under any circumstances."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width