ORA-01031: insufficient privileges
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 5 of 5

Thread: ORA-01031: insufficient privileges

  1. #1
    Join Date
    Feb 2002
    Posts
    4

    Question

    Hi I'm new to Oracle and computers and I need help.
    I installed Oracle 8.1.7 and OEM2.2 on Win2K. I could connect to the database as sysdba but now I can't anymore (either through DBAStudio or using SVRMGR). I keep getting ORA-01031: insufficient privileges

    I can connect using sys/change_on_install or system/manager or my own OS username/password, but not as sysdba.

    I know that in order to start up an Oracle database using the connect internal or connect / as sysdba syntax, the currently logged in OS user must be in the ORA_DBA Windows group, if the operating system is Windows NT or 2000. And I double-checked it already, in fact it was working fine before. Any idea about what might be happening?

    Thank you in advance.

    Heloisa

  2. #2
    Join Date
    Sep 2001
    Posts
    200
    to invoke svrmgr you you need to be the owner of the software. Usually Oracle in group dba on unix.
    Make sure that by the time you attempt to invoke svrmgr your id on the OS should be Oracle.
    hope this helps.
    Life is what is happening today while you were planning tomorrow.

  3. #3
    Join Date
    Feb 2002
    Posts
    4

    Question ORA-01031: only with sqlplus or srvmgrl !

    thanks for the reply.

    I don't know about UNIX, since i'm using Windows, but I guess when you talk about the dba group in UNIX is this same as ORA_DBA group in Windows.

    Here's some more information on the problem I'm having, if somebody can help...

    The parameter remote_login_passwordfile is set to exclusive
    and this is all I had in the password file were the users INTERNAL and SYS

    Then I added my OS username (part of the ORA_DBA group)to the password file.

    Now I am able to connect to the database as SYSDBA using DBA Studio and OEM, which I couldn't do before. Great!!!

    BUT... I still get the “Insufficient Privileges” error if I try to connect as sysdba through Srvmgrl or Sqlplus… What am I missing? If these users (sys and hp) are in the password file, why can't I connect as sysdba then?

    D:\>sqlplus sys/change_on_install
    SQL> connect / as sysdba
    ERROR:
    ORA-01031: insufficient privileges
    Warning: You are no longer connected to ORACLE.

    D:\>sqlplus hp/password
    SQL> connect / as sysdba
    ERROR:
    ORA-01031: insufficient privileges
    Warning: You are no longer connected to ORACLE.

    Thank you.

    Heloisa
    Heloisa

  4. #4
    Join Date
    Sep 2001
    Posts
    200
    I think when you use remote_login_passwordfile, you have to create a password file giving a password to both sys and internal. If you have then, you should be trying to connect to sqlplus/svrmgr as internal (sqlplus internal/XXX or simply sqlplus internal) and not sqlplus sys/change_on_install. Is this the password entered in you passwordfile?
    2/ When you log through dbastudio, oem you are coming in from the client side and powerful privileges are not an issue as opposed to invoking svmrgr/sqlplus directly.
    3/ Do you really need a passwordfile by the way? If you don't then comment it out in your pfile and recycle the instance and you can go back using INTERNAL OR SYSTEM

    Hope this helps.
    Life is what is happening today while you were planning tomorrow.

  5. #5
    Join Date
    Jan 2002
    Posts
    45
    I had ran into this problem a couple times, and the quickest workaround solution is the change the pwdSID.ora file. This is found under Oracle_Home/ora81/database path.

    Just simply make a copy of the pwdSID.ora file and delete the original one.

    After that, go to the command prompt (Start/run/cmd) and issue the following command:

    orapwd file=Oracle_home/ora81/database/pwdSID.ora password=pswd entries=n

    The entries option is optional and you can leave this one out.
    After that, you should be able to log in as internal/pswd. I normally restart the service just to make sure.

    Good luck

    John

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width