ORA-00439: feature not enabled: Managed Standby (When using DB Config Asst to create)
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: ORA-00439: feature not enabled: Managed Standby (When using DB Config Asst to create)

  1. #1
    Join Date
    Jan 2000
    Location
    Chester, England.
    Posts
    818

    Unhappy

    I've just installed 8.1.7 Standard Edition on an NT4 box. I've auto-created a default DB no problem during this.

    When I try to define a Custom DB using the Configuration Assistant and then press It fails with the error: ORA-01034: ORACLE not available.

    Checked some forums (fora?) and it seems to be something to do with the archive_log_dest init parameter. I've no details - sorry.

    As the auto-generated default DB is created in Non Archive Log mode this might explain why that worked.

    Can anyone shed any light on this? Is it peculiar to 8.1.7 Standard as I've created many DBs using 8.1.5 with no problems.

    I'm going to workaround by creating it in Non Archive Log mode and later enable logging when its up and running.

    Heres the dbcraete script generated by the Config Asst. ...


    Echo ON
    SVRMGR> connect INTERNAL
    Connected.
    SVRMGR> startup nomount pfile="C:\oracle\admin\prjcntl1\pfile\initPRJC1.ora"
    ORA-00439: feature not enabled: Managed Standby
    SVRMGR> CREATE DATABASE prjcntl1
    2> LOGFILE 'F:\oradata\prjcntl\proj01\prj_redo01.log' SIZE 1024K,
    3> 'F:\oradata\prjcntl\proj01\prj_redo02.log' SIZE 1024K,
    4> 'F:\oradata\prjcntl\proj01\prj_redo03.log' SIZE 1024K
    5> MAXLOGFILES 32
    6> MAXLOGMEMBERS 2
    7> MAXLOGHISTORY 1
    8> DATAFILE 'E:\oradata\prjcntl\proj01\system01.dbf' SIZE 264M REUSE AUTOEXTEND ON NEXT 10240K
    9> MAXDATAFILES 254
    10> MAXINSTANCES 1
    11> CHARACTER SET WE8ISO8859P1
    12> NATIONAL CHARACTER SET WE8ISO8859P1;
    CREATE DATABASE prjcntl1
    *
    ORA-01034: ORACLE not available
    SVRMGR> spool off

  2. #2
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    With standard edition you must not have multiple log_archive_destinations. If I remember well, you must change the name of the log_archive_dest_1 in your init to log_archive%_dest or something similar to workarround the problem, I donīt remember exactly now.

    The default database was created without problem, because it is created always in NOARCHIVELOG.

    I always create the database in noarchivelog, and after change it to archivelog, because if you create initially in archivelog mode, it will generate archiving when you create the catalogs.

    Hope that helps

    Angel

  3. #3
    Join Date
    Nov 2000
    Location
    Pittsburgh, PA
    Posts
    4,021
    When you install standard edition it will write archive logs to one local disk. It will not write them to a mapped disk. When you use the db create tool it sets up archive like you have enterprise. So you need to create the database as nonarchivelog and then when it has been created change it to archivelogmode. The enterprise edition syntax is also the default in the init file. So you will need to edit out the _1 and location= parts of the dest parameter.

    Enterprise Edition
    # log_archive_start = TRUE
    # log_archive_dest_1 = "location=D:\Oracle\oradata\bsg1\archive"
    # log_archive_format = %%ORACLE_SID%%T%TS%S.ARC

    Standard Edition
    # log_archive_start = TRUE
    # log_archive_dest = "D:\Oracle\oradata\bsg1\archive"
    # log_archive_format = %%ORACLE_SID%%T%TS%S.ARC

  4. #4
    Join Date
    Jan 2000
    Location
    Chester, England.
    Posts
    818
    Is this just with 8.1.7 though? I never had problems before (with 8.1.5).

    Thanks anyway, Angel. Your suggestion was what I planned to do anyway!

    John

  5. #5
    Join Date
    Jan 2000
    Location
    Chester, England.
    Posts
    818
    Perhaps we had installed 8.1.5 Enterprise Edition?? Not sure! If I install 8.1.7 Enterprise will it solve this?

    John

  6. #6
    Join Date
    Oct 2001
    Location
    Madrid, Spain
    Posts
    763
    Yes

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width