ORA-01034
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: ORA-01034

  1. #1
    Join Date
    Jun 2001
    Posts
    76
    All -

    I am not quite sure why, but all of a sudden, my database stopped working (8.1.5 on Solaris 7) and now I get error ORA-01034 when I try to run:
    %>sqlplus username/password@servicename

    I have tried setting TWO_TASK, increasing virtual memory, restarting the database, and restarting the machine.

    I also noticed that in listener.trc, I get the following message whenever I try to connect:

    nstimarmed: no timer allocated

    I am not sure if this is significant, but am now out of ideas. Any thoughts?

    R
    On the other hand, you have different fingers.

  2. #2
    Join Date
    Jun 2000
    Posts
    179

    Talking

    Does this happen when you connect on the server machine itself or from a client .

    It seems that you have a problem at the session level , if you have this problem happening from a client machine try to use an Oracle client from the same version or higher 8i Ver. 1 or later.

    Mainly Two task problem happen if there is a problem with the listener of from a conflict between SQL/Net8 networking layer.

    Check if you have lately altered the listener file and if so try to resotor a backup and reload the listener .

    Good Luck

    Hisham Nagia
    IT Manager For Development
    Oracle Consultant - OCP

  3. #3
    Join Date
    Jun 2001
    Posts
    76
    This happens when I am trying to connect from the localhost. The only change made to the system recently was to force 100M/full-duplex in /etc/system. I changed that back to how it was previously, but to no avail. I have checked, rechecked, and checked again the listener.ora,tnsnames.ora,etc... and there appears to be no problems.

    I have tried setting TWO_TASK, but that does not help either.

    One interesting note, is that when I run

    %>lsnrctl test ORCL.world

    I get the following:

    Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC0))(PROTOCOL_STACK=(PRESENTATION=TTC)(SESSION=NS)))
    TNS-12504: TNS:listener was not given the SID in CONNECT_DATA

    I have verified tnsnames.ora, and CONNECT_DATA is in there:

    ORCL.world =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS =
    (PROTOCOL = TCP)
    (HOST = 0.0.0.0)
    (PORT = 1520)
    )
    )
    (CONNECT_DATA = (SID = ORCL)
    )
    )

    What else can I look for to resolve this problem?

    R
    On the other hand, you have different fingers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width