Database startup
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 7 of 7

Thread: Database startup

  1. #1
    Join Date
    Oct 2001
    Location
    Jackson,MS,U.S.A
    Posts
    1

    Question Database hangs

    hi,
    I killed the user session with kill -9 pid command, as I can't kill it using alter system kill session, when a user session hung up.
    Then the user session still appears in the session list. I tried to shutdown the database with shutdown immediate. I could not. then I used shutdown abort. Then restarted the database. It gave the message as usual. i.e instance started, database mounted and opened. When I tried to connect the database from sqlplus, it gave the ora-1034 oracle not available error message. I chceked the database from unix prompt with ps -ef command. Surprisingly, I did not find any back ground process which should be there when the database is running .I shutdown again and restarted the database. But it is still in the same condition.
    Any help is apprecited and thanks in advance.
    Srinivasa Rao Chava

  2. #2
    Join Date
    Feb 2001
    Posts
    41
    Which version of Oracle are you using?

    Thanks

  3. #3
    Join Date
    Oct 2001
    Posts
    122

    Cool

    Please provide more detail -
    1. What version of Oracle and OS you are running?
    2. In what setup you are running your database (parellel server, stand by, replication etc.)
    3. What infastructure you have? I mean, how much memory, size of SGA wanting to start, swap etc.
    4. have you ever managed to start the same database successfully? or it is first time after installation?
    5. If it is first time startup, did you install it correcty as guided by Oracle docos? did you set kernal correctly?



  4. #4
    Join Date
    Jun 2000
    Location
    Chennai/India
    Posts
    90
    Hi,
    Sounds weired. Oracle DB will not mount without the background process starts. If this is so, pls report as a bug. AFAIK, Oracle database will not be accessible without any of background process running.
    A Winner never Quits, A Quitter never Wins
    Ganesh .R

  5. #5
    Join Date
    Sep 2001
    Location
    Makati, Philippines
    Posts
    857
    Woooh.... you might just kill a background process.
    I hope not.

  6. #6
    Join Date
    Jan 2000
    Posts
    387
    Please check your environment setting. Are you able to grep any Oracle processes?
    Even if you have killed an Oracle process, when you restart the database, it should
    start all the processes again...

  7. #7
    Join Date
    Apr 2001
    Location
    London
    Posts
    725
    try startup nomount.

    query status in v$instance.

    check processes exist.

    then alter database mount

    query v$database

    then alter database open.

    try to connect

    If Oracle tells you that the instance has started and the database is mounted and open, it must be. If it is not then you may need to contact Oracle Support.

    Once you have eliminated all of the impossible,
    whatever remains however improbable,
    must be true.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width