connect to database using sqlplus very slow
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 3 of 3

Thread: connect to database using sqlplus very slow

  1. #1
    Join Date
    Oct 2001
    Posts
    1

    Cool

    Platform: Sun Solaris
    DB Version: 8.1.7.2

    I see a delay of of 10 to 15 seconds before the SQL> prompt appears when I connect to using the following statement:

    $ sqlplus /

    I have checked to make sure that oracle tracing is not set, and I verified in the $ORACLE_HOME/otrace/admin directory, and there are not .dat files existing.

    I am not sure why it takes so much delay on this database alone, while it takes only 2 to 3 seconds to connect to other databases.

    I even tried tnsping and the response is less than 10 ms.

    Any help would be much appreciated.

  2. #2
    Join Date
    Jun 2001
    Location
    Helsinki. Finland
    Posts
    3,938
    How long time does it take to connect via FTP? If long, then the problem might not be within Oracle.

    You may try to to transfer the listener to another port. Before doing that however, check that you use the IP address of the database server in the listener.ora and tnsnames.ora files, check that tracing is not on (for the listener, SQL*Net too).

    Try to flush the shared pool: ALTER SYSTEM FLUSH SHARED_POOL; and add log_directory_client='null' to sqlnet.ora.


  3. #3
    Join Date
    Sep 2001
    Location
    NJ, USA
    Posts
    1,287
    If in tnsnames.ora set NAME of server:
    1) Try to set IP address to Oracle server directly
    2) Try type server name using full dot notation aaa.bbb.orsserver

    Check firewalls and proxy servers if they exists.
    Check tracerout from client box to oracle server.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Click Here to Expand Forum to Full Width