Urgent!!! USER EXIT error in Application logon
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: Urgent!!! USER EXIT error in Application logon

  1. #1
    Join Date
    Sep 2001
    Location
    OH
    Posts
    44
    Hi,

    When I try to start the application with
    URL: http://hostname.domainname:8000/TESTj,

    it shows following error messages.

    SECURITY-INVALID USERID
    (USERNAME = applsyspub)
    (PASSWORD=pub) (DATABASE=TEST)

    Then I generated Form trace log file for the form FNDSCSGN.fmb which is a logon form.

    It generated frd.log in which at the end of file, I have following error messages.


    Executing USER_EXIT Built-in:
    In Argument 0 - Type: String Value: FND FORM_INFO APPLICATION="FND" VERSION="$Revision: 110.32

    Executing GET_APPLICATION_PROPERTY Built-in:
    In Argument 0 - Type: Number Value: 73
    Out Argument 0 - Type: String Value: applsyspub

    Executing GET_APPLICATION_PROPERTY Built-in:
    In Argument 0 - Type: Number Value: 74
    Out Argument 0 - Type: String Value: pub

    Executing GET_APPLICATION_PROPERTY Built-in:
    In Argument 0 - Type: Number Value: 75
    Out Argument 0 - Type: String Value: TEST

    Executing USER_EXIT Built-in:
    In Argument 0 - Type: String Value: FND LOGON FNDNAM="apps" USERNAME="applsyspub" PASSWORD="pub" DATABASE="TEST"

    # 1 - FNDSCSGN:. - USER_EXIT
    END

    # 1 - FNDSCSGN:.
    USER_EXIT CHOICE OK

    # 2 - FNDSCSGN:. - USER_EXIT
    END

    # 2 - FNDSCSGN:.
    USER_EXIT CHOICE OK

    Executing FORM_SUCCESS Built-in:
    Out Argument 0 - Type: Boolean Value: FALSE

    Unhandled Exception ORA- 100501
    State Delta:
    ERROR PREMATURE_EXIT "Playback stopped before end of file (line 0)"


    It shows username, password and SID name correctly but still failes to connect. I am able to connect to applsyspub/pub@TEST from sqlplus.

    Can anybody help me find out reason?

    Thanks in advance.


    Sam


  2. #2
    Join Date
    Sep 2001
    Location
    Makati, Philippines
    Posts
    857
    Hi Sam,

    Why don't you try to include password and SID name in your
    userid in your serverArgs?

    Like:
    serverArgs="module=....../.../forms/US/FNDSCSGN userid=APPLSYSPUB/PUB@PRD fndnam=APPS"

    Keep it cool and
    Good luck!


  3. #3
    Join Date
    Sep 2001
    Location
    OH
    Posts
    44
    Originally posted by reydp
    Hi Sam,

    Why don't you try to include password and SID name in your
    userid in your serverArgs?

    Like:
    serverArgs="module=....../.../forms/US/FNDSCSGN userid=APPLSYSPUB/PUB@PRD fndnam=APPS"

    Keep it cool and
    Good luck!

    Hi Reydp,

    They are already there in html file.

    Any other idea?

    Thanks,

    Sam.

  4. #4
    Join Date
    Sep 2001
    Location
    Makati, Philippines
    Posts
    857
    Hi Sam,

    First I'd like to think that your problem
    was just maybe misused of ports, or incorrect
    user entry in DAD, but I guess not.

    I guess your problem is the USER_EXIT execution.
    Did you ever try to run the script USRXIT.SQL under
    the directory: $APPL_TOP/fnd/11.0.28/usrxit?

    Maybe there was an error upon execution?
    Or it should not be executed anyway to begin with, I'm not sure.
    Try to make a research on this.

    My advice, is to backup first the table IAPXTB.
    and delete user exit definition:
    delete from IAPXTB WHERE XTB$XNM IN ('XXX');
    where XXX is the user exit.

    And try again.

    I hope this leads to something good.

  5. #5
    Join Date
    Sep 2001
    Location
    OH
    Posts
    44
    Originally posted by reydp
    Hi Sam,

    First I'd like to think that your problem
    was just maybe misused of ports, or incorrect
    user entry in DAD, but I guess not.

    I guess your problem is the USER_EXIT execution.
    Did you ever try to run the script USRXIT.SQL under
    the directory: $APPL_TOP/fnd/11.0.28/usrxit?

    Maybe there was an error upon execution?
    Or it should not be executed anyway to begin with, I'm not sure.
    Try to make a research on this.

    My advice, is to backup first the table IAPXTB.
    and delete user exit definition:
    delete from IAPXTB WHERE XTB$XNM IN ('XXX');
    where XXX is the user exit.

    And try again.

    I hope this leads to something good.

    Hi,

    I did not find the table called 'IAPXTB'. How can I find or create it?

    Thanks,

    Sam.

  6. #6
    Join Date
    Sep 2001
    Location
    Makati, Philippines
    Posts
    857
    ok then,
    what is the value of your APPLUSER in your PRD.env?
    is it usrxit?

    If it is usrxit, then there might be other problem
    involved.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width