Euro symbol
DBAsupport.com Forums - Powered by vBulletin
Results 1 to 6 of 6

Thread: Euro symbol

  1. #1
    Join Date
    Oct 2001
    Location
    Portugal
    Posts
    6

    Question

    I’m using oracle server 8.1.6.0 with charset WE8ISO59P15 and I can’t put the euro symbol “€” inside the database…
    When using Toad 7.1.7 or SqlPlus I can’t even make the symbol at the sql editor.
    And it looks like some king of “Vertical bar” when I use Copy-> Paste from notepad.

    Does anyone knows how to solve this problem, I’ve check the forum search engine but I can’t find a solution…

    Please, tell me that someone as already experience this problem…

    Regards
    André R.

  2. #2
    Join Date
    Sep 2001
    Location
    NJ, USA
    Posts
    1,287
    Probably you have 2 problems:

    1. Check NLS_LANG key (parameter) in register, does it have valid character set (WE8ISO8859P15)

    2. Win NT (Win2000) has bug, copy-paste doesn'n correct if you turn on in ENG keyboard layout
    (try turn on in YOU_LANG keyboard layout and exec copy-paste).

  3. #3
    Join Date
    Oct 2001
    Location
    Portugal
    Posts
    6
    -----------------------------------------------------------------------
    Probably you have 2 problems:
    1. Check NLS_LANG key (parameter) in register, does it have valid character set (WE8ISO8859P15)
    -----------------------------------------------------------------------
    It was “NA” but now I change it to WE8ISO8859P15 (on the Client). It doesn’t change a lot…

    I have these parameters THAT I can get using Toad.

    Session
    NLS_CALENDAR = GREGORIAN
    NLS_COMP=BINARY
    NLS_CURRENCY=$
    NLS_DATA_FORMAT=RR.MM.DD
    NLS_DATA_LANGUAGE=PORTUGUESE
    NLS_DUAL_CURRENCY= ? (Inverted)
    NLS_NUMERIC_CHARACTERS=,.
    NLS_SORT=WEST_EUROPEAN
    NLS_TERRITORY=PORTUGAL
    ….

    Instance

    NLS_LANGUAGE=AMERICAN
    NLS_TERRITORY=AMERICA


    DATABASE
    NLS_LANGUAGE=AMERICAN
    NLS_TERRITORY=AMERICA
    NLS_CURRENCY=$
    NLS_ISO_CURRENCY=AMERICA
    NLS_CHARSET= WE8ISO8859P15
    NLS_DATA_FORMAT=DD-MON-RR
    NLS_DATE_LANGUAGE=AMERICAN
    NLS_SORT=BINARY
    NLS_DUAL_CURRENCY=$
    NLS_NCHAR_CHARACTERSET= WE8ISO8859P15


    where is the NLS_LANG parameter show?

    -----------------------------------------------------------------------
    2. Win NT (Win2000) has bug, copy-paste doesn'n correct if you turn on in ENG keyboard layout
    (try turn on in YOU_LANG keyboard layout and exec copy-paste).
    ----------------------------------------------------------------------

    I´m using the portuguese layout.... and it doesn´t work too!

    Plese give me some more information!
    tks!

  4. #4
    Join Date
    Sep 2001
    Location
    NJ, USA
    Posts
    1,287
    NLS_LANG parameter setup in Windows registry:

    key HKEY_LOCAL_MACHINE --> Software --> Oracle (1)

    key HKEY_LOCAL_MACHINE --> Software --> Oracle -->HOME0 (2)

    key HKEY_LOCAL_MACHINE --> Software --> Oracle --> ORACLE_HOMES --> ORACLE0 (3)

    check it.

    I don't see NLS_LANGUAGE in session NLS parameters.

  5. #5
    Join Date
    Oct 2001
    Location
    Portugal
    Posts
    6
    Ok, I’ve made the changes to NLS_LANG in the registry (Cliente side, ok?) and I’ve change 3 keys putting WEISO8859P15 where first was “NA”.

    My NLS_LANGUAGE in session NLS parameters is (was already) set to “Portuguese”

    But I can’t see the NLS_LANG value anywhere… where should I look, in the session parameters?

    What about the W2K bug, does MS have any patch for it? I’m using W2K SP2.

    Thanks for helping, please forgive my lack off knowledge but NLS parameters are complex for me by now.

  6. #6
    Join Date
    Sep 2001
    Location
    NJ, USA
    Posts
    1,287
    In all of theese keys must be string parameter NLS_LANG

    try to set NLS_LANG = PORTUGUESE_PORTUGAL.WE8ISO8859P15

    if it doesn't work then try

    NLS_LANG = AMERICAN_PORTUGAL.WE8ISO8859P15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width