Shared Server Mode (Connection slow)
DBAsupport.com Forums - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Shared Server Mode (Connection slow)

  1. #1
    Join Date
    May 2001
    Posts
    82

    Question

    Hi,

    I have a database in shared server mode. We have about 60 users.

    When I try to connect to this database it is very slow. But once it connects it is fast. What am I doing wrong? Should I be changing any parameters?

    I have gone thro' the tuning and performance routine and all the parameters seems to be fine.

    Please help.

    Thanks in advance.

    Radha.

  2. #2
    Join Date
    May 2001
    Posts
    82
    Any Suggestions???

  3. #3
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    did you do a ping to the server and see the response time? It could be a clog in your network.

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  4. #4
    Join Date
    May 2001
    Posts
    82
    ping

    It says:

    Ping statistics for..........
    Approximate round trip times in milli-seconds"
    Minimum=oms, Maximum = 0ms, Average=oms

    I am not sure if this helps.

    I had a database earlier which I configured as OLTP and Shared server mode. It was fast.

    Now the new database is Multipurpose and shared server mode.

    Any ideas?

    Thanks Sam.

    Radha.

  5. #5
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    How many MTS_dispatchers and MTS_SERVERS do you have?
    Could you do a tnsping on the listener ...

    tnsping database_server_name

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  6. #6
    Join Date
    May 2001
    Posts
    82


    MTS_DISPATCHERS = 2
    MTS_SERVERS = 2

    I tried tnsping

    It gives the foll. error

    TNS-03505: Failed to resolve name

  7. #7
    Join Date
    May 2001
    Posts
    82
    I am sorry MTS_SERVERS = 1

    MTS_DISPATCHERS = 2

    what should be the parameters for the value field of the MTS_DISPATCHERS ?

  8. #8
    Join Date
    May 2001
    Posts
    82
    Sam,

    tnsping

    gives the following

    OK (140 msec)

    Thank you.

    Radha.

  9. #9
    Join Date
    Oct 2000
    Location
    Saskatoon, SK, Canada
    Posts
    3,925
    Your MTS limits could be one of the reasons for the slow down.

    sqlplys sys/passwd@servicename

    ALTER SYSTEM SET MTS_SERVERS= 10;

    ALTER SYSTEM SET MTS_DISPATCHERS= '(PROTOCOL=TCP)(DISPATCHERS=2)'

    And now try the connections again. If they work fine then you have to make the appropriate changes in the appropriate init.ora file. So that you wouldn't use the old values...

    Sam
    Thanx
    Sam



    Life is a journey, not a destination!


  10. #10
    Join Date
    Jun 2001
    Location
    Helsinki. Finland
    Posts
    3,938
    Originally posted by s_radhak
    I am sorry MTS_SERVERS = 1

    MTS_DISPATCHERS = 2

    what should be the parameters for the value field of the MTS_DISPATCHERS ?
    1 dispatcher for 250 users is OK. Oracle will not start automatically more dispatchers if these are needed. You have to do that. On the other side Oracle will start more shared servers if needed. Give 1 server for 10 users. This is the geeral rule. However, if you run DSS, 5 is enough; in OLTP 20 would be OK.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  



Click Here to Expand Forum to Full Width